This article has not yet been verified against Umbraco 8.

    The concepts and code examples might not work if you are running Umbraco 8.0 or a later version. If you are using Umbraco 7, this article is perfect for you!

    You are more than welcome to report any issues found on the Documentation Issue Tracker.

    Dependencies on Umbraco Cloud

    This article gives an overview of the dependencies between the products on Umbraco Cloud.

    The products are:

    • Umbraco CMS
    • Umbraco Forms
    • Umbraco Courier
    • Umbraco Deploy

    In the table below you can see which version of Umbraco Forms and Courier / Deploy you should be running on your Umbraco Cloud project depending on which version of Umbraco CMS, you are running.

    Umbraco CMS Umbraco Forms Umbraco Courier Umbraco Deploy
    < 7.5 4.x 3.x --
    7.5 4.x 3.x --
    7.6 6.x -- 1.x
    7.7 6.x -- 2.x
    7.8 6.x -- 2.x
    7.9 < 7.x -- 2.x
    8.0 < 8.x -- 3.x

    NOTE: All Umbraco Cloud projects running Umbraco 7.6 or above should be using Umbraco Deploy instead of Umbraco Courier. If you are upgrading from Umbraco 7.5.x to 7.6 or above, you also need to replace Umbraco Courier with Umbraco Deploy.

    How to upgrade Umbraco CMS manually

    How to upgrade Umbraco Forms manually

    How to upgrade Umbraco Courier / Deploy manually