Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Rasmus Fjord 657 posts 1542 karma points c-trib
    Jul 24, 2013 @ 13:34
    Rasmus Fjord

    umbraco on azure "The device is not ready" bug

    Hey there :)

    We moved a customer to azure hosting a while back and its been running with no props. Now the customer calls and the site didnt have any content, then i saw this bug being traced : 


    2013-07-24 00:00:45,958 [7] WARN  umbraco.macro - [Thread 16] Error loading MacroEngine script (file: blablablamacro.cshtml, Type: ''. Exception: System.IO.IOException: The device is not ready.

    at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
       at System.IO.FileStream.ReadCore(Byte[] buffer, Int32 offset, Int32 count)
       at System.IO.FileStream.Read(Byte[] array, Int32 offset, Int32 count)
       at System.IO.BinaryReader.Read(Byte[] buffer, Int32 index, Int32 count)
       at Lucene.Net.Store.SimpleFSDirectory.SimpleFSIndexInput.ReadInternal(Byte[] b, Int32 offset, Int32 len)
       at Lucene.Net.Store.BufferedIndexInput.Refill()
       at Lucene.Net.Store.BufferedIndexInput.ReadByte()
       at Lucene.Net.Store.IndexInput.ReadVInt()
       at Lucene.Net.Index.FieldsReader.Doc(Int32 n, FieldSelector fieldSelector)
       at Examine.LuceneEngine.SearchResults.CreateFromDocumentItem(Int32 i)
       at Examine.LuceneEngine.SearchResults.d__1.MoveNext()
       at System.Linq.Enumerable.Any[TSource](IEnumerable`1 source)
       at umbraco.MacroEngines.ExamineBackedMedia.GetUmbracoMedia(Int32 id)
       at umbraco.MacroEngines.Library.RazorLibraryCore.MediaById(Int32 Id)
       at umbraco.MacroEngines.DynamicNode.MediaById(String Id)
       at ASP._Page_macroScripts_blablabla_cshtml.Execute() in c:\DWASFiles\sites\sitename-\VirtualDirectory0\site\wwwroot\macroScripts\blablabla.cshtml:line 48
       at System.Web.WebPages.WebPageBase.ExecutePageHierarchy()
       at System.Web.WebPages.WebPage.ExecutePageHierarchy()
       at System.Web.WebPages.WebPageBase.ExecutePageHierarchy(WebPageContext pageContext, TextWriter writer, WebPageRenderingBase startPage)
       at umbraco.MacroEngines.RazorMacroEngine.ExecuteRazor(MacroModel macro, INode currentPage)
       at umbraco.MacroEngines.RazorMacroEngine.Execute(MacroModel macro, INode currentPage)
       at umbraco.macro.loadMacroScript(MacroModel macro)
       at umbraco.macro.renderMacro(Hashtable pageElements, Int32 pageId)
    Then i restarted the solution and now it works again, but how can this occur. There is nothing supcious in the logs besides a ton of macros not being ready "The device is not ready". Except one other bug, when i was notified i first tried to rebuild the umbraco.config file but in the logs it says this : 
    System.UnauthorizedAccessException: Access to the path 'C:\DWASFiles\Sites\blablabla\VirtualDirectory0\site\wwwroot\App_Data\umbraco.config' is denied.
    The site is running on a "Standard" website small(dedicated) instance with the default web sql server.
    The umbraco is a umbraco 4.11.8
    Anyone who can help here or get me any closer to why ? 
  • Rasmus Fjord 657 posts 1542 karma points c-trib
    Oct 16, 2013 @ 10:20
    Rasmus Fjord

    BUMP im seeing this error again on 2 different azure sites. 

    Both running Azure website standard but on different umbraco versions (4.11.x and 6.1.x).

    Its only on images that the files apper to be locked, when we restart the sites it just works again.

  • Lars Draco 1 post 21 karma points
    Oct 18, 2013 @ 16:56
    Lars Draco

    I have the same issue. Umbraco web site on Azure. After restart of the web site it works just fine. Please help.

  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Oct 23, 2013 @ 09:48
    Darren Ferguson

    Is it single or multi instance? This looks like an issue with the examine indexes, rather than the media files.

    Umbraco fundamentally doesn't work on load balanced Azure websites - for a number of reasons, one of which is Examine doesn't support writes from multiple instances.

  • Rasmus Fjord 657 posts 1542 karma points c-trib
    Oct 23, 2013 @ 11:15
    Rasmus Fjord

    This is a Website standard (dedicated website) but its not load balanced in anyway.

    And both the sites im seeing this happening on has their own "Website standard" with no other websites running then the primary


  • Darren Ferguson 1022 posts 3258 karma points MVP c-trib
    Oct 23, 2013 @ 11:43
    Darren Ferguson

    OK that is odd - but the exception is to do with access to the examine indexes rather than the media files themselves....

    Not seen this before - but haven't really deployed any real sites into Azure websites - as it doesn't support Umbraco (in the fashion that we would like).


  • Rasmus Fjord 657 posts 1542 karma points c-trib
    Oct 23, 2013 @ 12:31
    Rasmus Fjord

    Okay, Thx for your inputs Darren ill take them into account and add them, on to a bug since its something that is standing in the way for azure hostings in general.

  • Shannon Deminick 1500 posts 5123 karma points hq
    Aug 31, 2015 @ 13:04
Please Sign in or register to post replies

Write your reply to: