Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Alex Burr 77 posts 128 karma points
    Jul 14, 2010 @ 17:38
    Alex Burr

    No Document exists with Version '00000000-0000-0000-0000-000000000000'

    Trying to install Runway from within the Umbraco "Developer" tab is continually giving me this error:


    Server Error in '/' Application.

    No Document exists with Version '00000000-0000-0000-0000-000000000000'

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentException: No Document exists with Version '00000000-0000-0000-0000-000000000000'

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [ArgumentException: No Document exists with Version '00000000-0000-0000-0000-000000000000']
       umbraco.cms.businesslogic.web.Document.setupNode() +1469
       umbraco.cms.businesslogic.CMSNode..ctor(Guid uniqueID) +429
       umbraco.cms.businesslogic.Content..ctor(Guid id) +91
       umbraco.cms.businesslogic.web.Document..ctor(Guid id) +107
       umbraco.cms.businesslogic.web.Document.GetRootDocuments() +421
       umbraco.cms.businesslogic.web.Document.MakeNew(String Name, DocumentType dct, User u, Int32 ParentId) +1859
       umbraco.cms.businesslogic.web.Document.Import(Int32 ParentId, User Creator, XmlElement Source) +415
       umbraco.cms.businesslogic.packager.Installer.InstallBusinessLogic(Int32 packageId, String tempDir) +8233
       umbraco.presentation.developer.packages.Installer.processInstall(String currentStep) +406
       umbraco.presentation.developer.packages.Installer.Page_Load(Object sender, EventArgs e) +933
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       umbraco.BasePages.BasePage.OnLoad(EventArgs e) +74
       System.Web.UI.Control.LoadRecursive() +116
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2750

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

    Apparently the style sheets, templates and document types get added anyway, but the only Content that is created is the Runway Homepage, which is unpublished with no actual content in it. I do seem to be able to go back and add additional Runway modules such as Top navigation, but this error is worrying me.

    This is on Win Server 2007 64 bit. IIS 7, .NET 4.0

    Umbraco is in default app pool which runs as NetworkService, which has Full Control over the folder.

  • xleon 21 posts 43 karma points
    Jul 19, 2010 @ 19:25

    I´m getting exactly the same error. Everything seems to work ok until I select any tree node (content, media, etc) and click "create" and then select any folder

    My scenario:

    Umbraco webdeploy 4.5
    NET 4.0
    IIS 7 default app pool which runs as NetworkService, which has Full Control over the folder
    Windows 7 32 bit

    Getting umbraco to work is been a hard task!

  • xleon 21 posts 43 karma points
    Jul 19, 2010 @ 21:50

    Now I realised this doesn´t happen when I use mouse right click to create items. 
    The error comes from the modal windows that pops up when you click "create" button.

  • Peter Gregory 407 posts 1612 karma points MVP 3x admin c-trib
    Jul 19, 2010 @ 23:18
    Peter Gregory

    Hi could you please report this bug on  and we can include it in the fixes for 4.5.1



  • Medjeti 75 posts 126 karma points
    Jul 23, 2010 @ 13:30


    I'm getting the same error when sorting, creating new documents and installing (certain?) packages.

    I filed the issue on Codeplex: - hopefully someone will be able to make sense of it.

    In the meantime, this is a major showstopper for the project I'm working on right now.
    If anybody has an idea on how to temporarily fix or work around this issue that'd be fantastic!

    Thanks in advance :)

  • Medjeti 75 posts 126 karma points
    Jul 23, 2010 @ 17:58

    Okay, I found a temporary fix!

    It seems I had a "ghost node" of sorts floating around that seems to have caused the problem: I had previously installed (and uninstalled) the [EyeCatch]_Sitemap_Generator_1.2 package - but when I looked in the umbracoNodes table, there was an entry that related to this package. After deleting the row in question, I haven't experienced the problem.

    As far as I can gather, Umbraco tries to match umbracoNodes (of type "Content") with the cmsContent table and subsequently the cmsContentVersion table - if the node doesn't have a corresponding entry in the cmsContent table, it will fail when trying to look up versions for the content. Or something like that.

    Anyways, I concocted the following SQL statement that might help identifying "ghost nodes":

    SELECT * FROM umbracoNode, cmsContent -- return nodes
    nodeObjectType = 'C66BA18E-EAF3-4CFF-8A22-41B16D66A972' -- that are of type 'Content'
    AND NOT IN (SELECT nodeId FROM cmsContent) -- but are not in the 'Content' table

    No guarantees, but it might be of help to somebody... On the other hand, there's a significant probability that I have completely misunderstood everything :)

  • overflew 87 posts 110 karma points
    Aug 03, 2010 @ 08:01

    Great, thanks Medjeti...

    Seems I have large volume of nodes turning up with that query, with the node title 'Example content page' - got to figure out who those got there.

    Could you please post the SQL delete query you use to safely(ish) remove those nodes?

  • Thomas.R 39 posts 62 karma points
    Aug 06, 2010 @ 13:19

    This fix did not worked for me, i have no nodes which are not in the cmsContent table. In fact, i have only one node in my fresh umb4.5 install.

    This problems is for me, related to another, go to URL /umbraco/editContent.aspx?id=1065 (change 1065 to an existing node id) => Save and publish, the result is an empty editing page for me.

  • Connie DeCinko 931 posts 1159 karma points
    Aug 16, 2010 @ 22:54
    Connie DeCinko

    I seem to only get it when trying to create a new root node.  Nodes created below do not have this issue. Interesting thing, even though I got the error, the node was still created.


  • Medjeti 75 posts 126 karma points
    Aug 17, 2010 @ 23:56

    @overflew: Sorry for not responding sooner.

    I don't have an in-depth understanding of the Umbraco database and I could have just been lucky to find something that resembled a fix. Thomas R's response also indicates that there might be something else at play.

    I had an almost-new install of Umbraco so it wasn't a big gamble for me, but if I had a significant amount of content, I'd be very hesitant to delete stuff from the DB without knowing how things are related and without at least some sort of official word on this bug.

    On the other hand, if it's your last resort it might be worth a shot. Make sure you back everything up. TWICE. And make sure you are able to restore from your backup. Then substitute "SELECT *" with "DELETE" in the SQL statement above and the nodes are gone.

    If you give it a go please let us know how it works out.

  • Connie DeCinko 931 posts 1159 karma points
    Jan 19, 2011 @ 18:35
    Connie DeCinko

    Deleted the same orphaned record and it appears to have resolved my problem.


  • Kurniawan Kurniawan 202 posts 225 karma points
    Feb 11, 2011 @ 06:18
    Kurniawan Kurniawan



    I have solved the problem, by deleting it.

    But I get another problem where umbraco examine can't crawled the node to build index,

    it only happen per node when I hit save and publish.

    Do you think this is the related problem where there is ghost node exists ?



  • Chris Randle 67 posts 181 karma points c-trib
    Sep 27, 2012 @ 14:53
    Chris Randle

    Yes - deleting works.  See this post for the Umbraco v4.9 solution.

  • singer777 69 posts 80 karma points
    Jan 12, 2013 @ 22:23

    Here's a quick fix that I did that did not involve going into the database: Simply delete that node in the content area. Then create a new one, with the same name, in its place. If it has nodes under it, they work if you just move them under the new one you created. Good luck!

Please Sign in or register to post replies

Write your reply to: