Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Craig100 1072 posts 2359 karma points c-trib
    Mar 11, 2014 @ 02:43
    Craig100
    0

    No Thumbnails in DAMP

    V6.1.6 MVC site using DAMP 2.7 and CropUp with DAMP CropUp files added and the DAMP Razor Value Convertor.  

    Page has a DAMP picker showing "Choose" and "Create". I can choose an image ok and the thumbnail size in the DAMP selector responds to changing size in the Data Type so I get the impression it's "connected". However, once the images is selected, nothing appears in the UI. It just shows "Choose" & "Create" again.  The DataType  is set to use a crop alias of "crops" which is the alias of the "Crops" property on added to the Image type. Pulling hair out again. 

    Any advice appreciated.

  • Jeroen Breuer 4861 posts 12136 karma points MVP 3x admin c-trib
    Mar 11, 2014 @ 12:11
    Jeroen Breuer
    0

    Hello,

    The CropUp files are for DAMP 2.5 and haven't been updated to DAMP 2.7. Sorry for that. You could try to download the Hybrid Framework and copy all DAMP files from there. That version should work.

    Jeroen

  • Craig100 1072 posts 2359 karma points c-trib
    Mar 11, 2014 @ 14:12
    Craig100
    0

    Thanks Jeroen. The only reason we're using the latest V6 is because of the delay in V7.1 because we need an image cropper and the client won't wait.  Looks like they'll have to wait anyway while we try out the hybrid framework.

  • Jeroen Breuer 4861 posts 12136 karma points MVP 3x admin c-trib
    Mar 11, 2014 @ 14:25
    Jeroen Breuer
    0

    V7 already has an Image Cropper package which works pretty well if you can't wait for 7.1: http://our.umbraco.org/projects/backoffice-extensions/v7-image-cropper

    Jeroen

  • Craig100 1072 posts 2359 karma points c-trib
    Mar 15, 2014 @ 22:38
    Craig100
    0

    Thanks Jeroen,

    So decided we'd go with V7.0.4 and try out the Image Cropper package assuming we could swap it out later when 7.1 comes out. However, after installing ImageGen, trying to install the Image Cropper Package zip locally gives this in the installation UI:-

    Binary file errors detected

    Read more...

    This package contains .NET binary files that might not be compatible with this version of Umbraco. If you aren't sure what these errors mean or why they are listed please contact the package creator.

    Error report

    This package could not be verified for compatibility. An error occurred while loading a referenced assembly 'HtmlAgilityPack' see error log for full details.

     

    Any advice appreciated.

    Craig

  • Craig100 1072 posts 2359 karma points c-trib
    Mar 16, 2014 @ 00:59
    Craig100
    0

    Ok, as everywhere I turn with Umbraco I'm stopped from progressing, I decided to return to the same set up I used for the last project I did, as at least that worked. So, for the record I've now had to totally abandon V7.0.4 and V6.1.6 and return to V6.1.5 with DAMP 2.5 and CropUp 1.0.0B3. 

    Let's hope this situation gets managed better in the future as it must cost developers and fortune in false starts when believing the spin on latest releases.

    Cheers,

    Craig

Please Sign in or register to post replies

Write your reply to:

Draft