Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Khai 71 posts 161 karma points
    Jul 01, 2014 @ 12:12
    Khai
    0

    newsletter studio 1.3.3 stuck sending emails

    Hi,

    A client is using newsletter studio 1.3.3 with Umbraco 6.0.2 in a shared hosting environment. They are trying to send out a newsletter but it has been stuck sending 300/562 emails for quite a long time now. I cannot find anything in the logs either. After reading, through the comments, it might be a bug with restarting the thread that sends out the email? Is there any way to fix this without upgrading? 

     

  • Markus Johansson 1624 posts 4581 karma points
    Jul 06, 2014 @ 12:19
    Markus Johansson
    0

    Hi!

    The best way to fix this is to upgrade as this will solve the issue. There is no custom work arounds except for exporting a list of the subscribers that has not got the email and import them as a new mailing list.

    You can read more about the statuses here: http://support.newsletterstudio.org/customer/portal/articles/1161249-what-does-all-the-statuses-mean-

    Has this happened before? That the sending thread gets killed?

    // Markus

  • Khai 71 posts 161 karma points
    Jul 07, 2014 @ 12:04
    Khai
    0

    Hi, 

    Thank you for your response. I see, so the steps i'd have to take for upgrading is:

    1. Export subscribers
    2. Uninstall package
    3. Install newsletter studio 1.4.4.2
    4. Import subscribers
    Well it's the first time the client actually used newsletter studio to send a newsletter.. I tested it before with a small list of subscribers, worked out well back then. I did try to send the newsletter a second time, but it also got stuck.

     

     

  • Markus Johansson 1624 posts 4581 karma points
    Jul 07, 2014 @ 13:44
    Markus Johansson
    0

    Hi!

    Yes, these steps should do the trick. Also make sure that there is write access to the umbraco and the umbraco_client-folders. 

    You may have issues with the tinymce.Config file after the upgrade so take a backup of you files before uninstalling.

    Another tips is to remove all tables in the db that starts with ns_ since the uninstaller will not remove them. 

    Please let me know if you have any issues. Just provive any error messages and I'll help you. 

    / m
     

  • Khai 71 posts 161 karma points
    Jul 08, 2014 @ 17:30
    Khai
    0

    Hi Markus, i managed to install the new version succesfully. But adding a template in the newsletter editor doesn't seem to work completely, it looks like it misses some css or whatever:

     

     

  • Markus Johansson 1624 posts 4581 karma points
    Jul 08, 2014 @ 20:06
    Markus Johansson
    0

    Hi!

    Feels like some settings in the tinyMCE.config-file? Looks like there is something wrong with the settings of the HTML-stripping. Could you copy the tinyMCE file from your old install or another working copy of umbraco with Newsletter Studio installed?

    / m 

  • Khai 71 posts 161 karma points
    Jul 08, 2014 @ 20:35
    Khai
    0

    Actually, the install did not modify anyting at the tinyMCE.config file, so I actually already copy pasted the backup file ( the 1.3.3 tinymce.config version ) back because there were no buttons in the editor. 

  • Markus Johansson 1624 posts 4581 karma points
    Jul 08, 2014 @ 20:40
    Markus Johansson
    0

    Hi Khai!

    Does the editor strip other HTML as well? Like if you insert an image or so? Or is it just the import template feature that dosent work?

    Did you reset the cache?

    / m 

  • Khai 71 posts 161 karma points
    Jul 08, 2014 @ 20:56
    Khai
    0

    Hmm inserting an image doesn't seem to work either ! the other functions like bold, making lists, links and tables are working though. Do you mean resetting the cache with iis reset? that doesn't seem to do the trick as well.

  • Markus Johansson 1624 posts 4581 karma points
    Jul 08, 2014 @ 21:58
    Markus Johansson
    0

    I bet that its wrong in the HTML-stripping settings. Can you compare your settings with another install? Clean the browser cache, disable any client dependency, restart the app.

    cheers! 

  • Khai 71 posts 161 karma points
    Jul 09, 2014 @ 12:36
    Khai
    0

    hmm I did a clean install on a new umbraco environment and the tinymceconfig looks the same. copy pastying it in the current project didn't work.. decided to revert the website to 1.3.3 again and redo the uninstall and installation but right now i'm getting this error when openining/creating a newsletter:

    No node exists with id '1315'

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 

    Exception Details: System.ArgumentException: No node exists with id '1315'

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace: 

    [ArgumentException: No node exists with id '1315']
       umbraco.cms.businesslogic.CMSNode.setupNode() +323
       umbraco.cms.businesslogic.datatype.DataTypeDefinition.setupNode() +44
       umbraco.cms.businesslogic.datatype.DataTypeDefinition.GetDataTypeDefinition(Int32 id) +124
       NewsletterStudio.Pages.Newsletter.Page_Init(Object sender, EventArgs e) +1728
       System.Web.UI.Page.OnInit(EventArgs e) +102
       umbraco.BasePages.UmbracoEnsuredPage.OnInit(EventArgs e) +89
       System.Web.UI.Control.InitRecursive(Control namingContainer) +186
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2098
  • Markus Johansson 1624 posts 4581 karma points
    Jul 09, 2014 @ 13:02
    Markus Johansson
    0

    Hi!

    It sounds like the TinyMCE data type id is wrong?

  • Khai 71 posts 161 karma points
    Jul 09, 2014 @ 13:44
    Khai
    0

    seems like it, but i don't know where and how to configure the right ID. Could it also be a problem that the database still has references to old data types that are not removed by uninstalling the package?

  • Khai 71 posts 161 karma points
    Jul 09, 2014 @ 14:31
    Khai
    0

    i got it working after repeating the steps.. a thing i noticed when deploying on the test environment is that i get a code access security exception.. is 1.4.4.2 not medium trust compatible anymore? That would not work in my case because we are hosting in a medium trust shared environment. What do you advice to do now?

  • Markus Johansson 1624 posts 4581 karma points
    Jul 09, 2014 @ 19:41
    Markus Johansson
    0

    Hi!

    As far as I know there is no changes that should impact this but Newsletter Studio has never had an "offical" support for medium trust.

    It there any issues that you are experiencing?

    / m 

  • Khai 71 posts 161 karma points
    Jul 10, 2014 @ 10:37
    Khai
    0

    Hm, i thought i had read that newsletter studio did support medium trust in the past, but i can't really remember. yes, if I open the newsletter section, i get an exception, this did not happen with 1.3.3, I'm testing it by setting the trust level in the web.config on the test server, so there must have been some changes:

    Security Exception

    Description: The application attempted to perform an operation not allowed by the security policy.  To grant this application the required permission please contact your system administrator or change the application's trust level in the configuration file. 

    Exception Details: System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.ReflectionPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

    Source Error: 

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace: 

    [SecurityException: Request for the permission of type 'System.Security.Permissions.ReflectionPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.]
       System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet) +0
       System.Security.CodeAccessPermission.Demand() +54
       System.Reflection.Emit.DynamicMethod.PerformSecurityCheck(Type owner, StackCrawlMark& stackMark, Boolean skipVisibility) +565
       System.Reflection.Emit.DynamicMethod..ctor(String name, Type returnType, Type[] parameterTypes, Type owner, Boolean skipVisibility) +76
       ၧĜ鶓뤴␴㵽�(RuntimeFieldHandle f) +1225
  • Markus Johansson 1624 posts 4581 karma points
    Jul 10, 2014 @ 10:48
    Markus Johansson
    0

    Hi Khai!

    Nope we have never had an official support for medium trust.  

    Do you have a longer version of the stack trace? We added a new data layer in 1.3.4 but that should not use anything that cant be used with medium trust (as far as I know). It would be nice to know more about this - does the newsletter tree load? Can you load other pages? Like the edit newsletter-view? Or looking at analytics? Can you open the a mailing list details page?

  • Khai 71 posts 161 karma points
    Jul 10, 2014 @ 14:13
    Khai
    0

    i see ok :) 

    Nothing actually loads, there are no nodes in the tree so i cannot go to the other pages. This is the trace log:

    2014-07-10 14:11:39,514 [10] ERROR Umbraco.Core.UmbracoApplicationBase - [Thread 19] An unhandled exception occurred

    System.TypeInitializationException: The type initializer for '????????' threw an exception. ---> System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.ReflectionPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

       at System.Security.CodeAccessSecurityEngine.Check(Object demand, StackCrawlMark& stackMark, Boolean isPermSet)

       at System.Security.CodeAccessPermission.Demand()

       at System.Reflection.Emit.DynamicMethod.PerformSecurityCheck(Type owner, StackCrawlMark& stackMark, Boolean skipVisibility)

       at System.Reflection.Emit.DynamicMethod..ctor(String name, Type returnType, Type[] parameterTypes, Type owner, Boolean skipVisibility)

       at ??G?????(RuntimeFieldHandle f)

       --- End of inner exception stack trace ---

       at ????????.????????(Object )

       at NewsletterStudio.Usercontrols.Dashboard.Page_Load(Object sender, EventArgs e)

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Control.LoadRecursive()

       at System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

       at System.Web.UI.Page.ProcessRequest(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint)

       at System.Web.UI.Page.ProcessRequest()

       at System.Web.UI.Page.ProcessRequest(HttpContext context)

       at ASP.umbraco_dashboard_aspx.ProcessRequest(HttpContext context) in c:\Windows\Microsoft.NET\Framework64\v4.0.30319\Temporary ASP.NET Files\root\f2102307\bb5afe6b\App_Web_dashboard.aspx.5f2dec3.0vgdpmxd.0.cs:line 0

       at System.Web.HttpApplication.CallHandlerExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously)

     

     

  • Markus Johansson 1624 posts 4581 karma points
    Jul 15, 2014 @ 13:16
    Markus Johansson
    0

    Does other parts of Umbraco work as expected? 

    Since PetaPoco (the mini-ORM used by Umbraco and Newsletter Studio 1.4+) uses reflection we need this to work. And MS has also made medium trust obsolete.

    "The official position of the ASP.NET team is that Medium Trust is obsolete"

    http://stackoverflow.com/questions/18147973/entity-framework-6-and-system-security-permissions-reflectionpermission-under-go ;

    http://support.microsoft.com/kb/2698981

Please Sign in or register to post replies

Write your reply to:

Draft