Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Rick van der Meij 35 posts 135 karma points
    Oct 07, 2014 @ 15:01
    Rick van der Meij
    0

    CustomData column update v2.0.0 to v2.1.0

    After the update we were missing this column in the emailTrackingItems table. Don't know if it is a bug or if its related to db security, or because it is a upgrade.

  • Markus Johansson 1608 posts 4535 karma points
    Oct 07, 2014 @ 16:53
    Markus Johansson
    0

    Hi!

    There should have been a column inserted during the install. Try to run this:

    ALTER TABLE ns_EmailTrackingItems ADD CustomData NVARCHAR(MAX) 

  • Rick van der Meij 35 posts 135 karma points
    Oct 08, 2014 @ 08:33
    Rick van der Meij
    0

    Yes we have added the Table to get it working again. We were just wondering if it happened just to us for security reasons on the database. I guess that is the case then.

  • Markus Johansson 1608 posts 4535 karma points
    Oct 08, 2014 @ 09:23
    Markus Johansson
    0

    Hi!

    There should be a task that runs during the installation that adds this table. I has passed our testing but I will be double checkning this as well. The problem only seem to appear during upgrades.

    Thanks for sharing your issues.


    /  m

  • Rick van der Meij 35 posts 135 karma points
    Oct 23, 2014 @ 09:27
    Rick van der Meij
    0

    I just updated another one from version 2.0.0 to 2.1.0 and the same table error did occur

  • Markus Johansson 1608 posts 4535 karma points
    Oct 23, 2014 @ 09:36
    Markus Johansson
    0

    Hi Rick!

    Okey. I will try again to reproduce this issue - it did "work for me" when we tested it.

    Thank you for sharing your problems.

    // m 

  • Vincent Baaij 95 posts 344 karma points c-trib
    Oct 23, 2014 @ 10:41
    Vincent Baaij
    0

    Markus,

    Another problem we see with these upgrades (Rick is my colleague) is that the scheduled tasks for Newsletter Studio are duplicated in umbracosettings.config.

    Fortunately the error you get when you start the site makes it pretty clear what the problem is.

  • Peter Steiner 8 posts 61 karma points
    Apr 02, 2015 @ 18:46
    Peter Steiner
    0

    Just FYI, I had to execute the database column addition SQL manually too to fix Newsletter Studio after the upgrade to the latest version.

    Note that my installer also seemed to hang in some kind of redirect loop at the final step where it said "loading newsletter studio" at the end of the package installer... maybe this is where this occurs and it never really finished in a correct way.

    Regards, Peter

  • Markus Johansson 1608 posts 4535 karma points
    Apr 07, 2015 @ 11:03
    Markus Johansson
    0

    Hi!

    Thank you Peter!

    It's really hard to make the upgrade experiance totally flawless but we're working hard on it - I'll post this as a bug and will investigate it closer.

    / m 

Please Sign in or register to post replies

Write your reply to:

Draft