Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


This forum does not allow new topics to be created, please use the v2 forum from now on.

  • rob 75 posts 170 karma points
    Apr 19, 2013 @ 09:51
    rob
    0

    upgrade from 4.11.3 to 6.0.2 give null reference exception in back end

    after runngin the upgrade from 4.11.3 to 6.0.2 successfully, front end all works fine but any content page in back end gives 

    [NullReferenceException: Object reference not set to an instance of an object.]
       umbraco.cms.businesslogic.datatype.DataTypeDefinition.get_DataType() +445
       umbraco.cms.businesslogic.Content.<InitializeProperties>b__e(Property x) +103
       System.Linq.WhereSelectEnumerableIterator`2.MoveNext() +247
       System.Collections.Generic.List`1.InsertRange(Int32 index, IEnumerable`1 collection) +551
       umbraco.cms.businesslogic.Content.InitializeProperties() +281
       umbraco.cms.businesslogic.Content.getProperty(String alias) +59
       umbraco.controls.ContentControl.LoadPropertyTypes(IContentTypeComposition contentType, TabPage tabPage, Hashtable inTab, Int32 tabId, String tabCaption) +333
       umbraco.controls.ContentControl.CreateChildControls() +803
       System.Web.UI.Control.EnsureChildControls() +188
       umbraco.controls.ContentControl.OnInit(EventArgs e) +50
       System.Web.UI.Control.InitRecursive(Control namingContainer) +185
       System.Web.UI.Control.AddedControl(Control control, Int32 index) +188
       umbraco.cms.presentation.editContent.OnInit(EventArgs e) +1230
       System.Web.UI.Control.InitRecursive(Control namingContainer) +185
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +2097

    which relates to the app guid for 301 redirector, uninstalling and reinstalling, and then copying data back from backup restored system.

  • Jan Skovgaard 11263 posts 23588 karma points MVP 8x admin c-trib
    Apr 20, 2013 @ 18:33
    Jan Skovgaard
    0

    Hi Rob

    Did you remember to install the fix path package and run the script against the database? 

    You can read more about the issue here http://umbraco.com/follow-us/blog-archive/2013/2/1/umbraco-4114-released.aspx

    Hppe this helps.

    /Jan

Please Sign in or register to post replies

Write your reply to:

Draft