Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


This forum does not allow new topics to be created, please use the v2 forum from now on.

  • Michael Nielsen 82 posts 361 karma points
    Apr 21, 2013 @ 21:00
    Michael Nielsen
    0

    Redirects just gives Umbraco 404 page

    Creating redirects does nothing, it still just shows the 404 page.

    Redirects and their mappings are visible in the backend.

    404handlers.config looks like this

    <?xml version="1.0" encoding="utf-8"?>
    <NotFoundHandlers>
      <notFound assembly="umbraco" type="SearchForAlias" />
      <notFound assembly="umbraco" type="SearchForTemplate" />
      <notFound assembly="umbraco" type="SearchForProfile" />
      <notFound assembly="uComponents.NotFoundHandlers" type="MultiSitePageNotFoundHandler" />
      <notFound assembly="uComponents.NotFoundHandlers" type="SearchFor301MovedPermanently" />
      <notFound assembly="uComponents.NotFoundHandlers" type="SearchForPageNotFound" />
      <notFound assembly="InfoCaster.Umbraco._301UrlTracker" type="Handler301URLTracker" />
      <notFound assembly="umbraco" type="handle404" />
    </NotFoundHandlers>

    Umbraco 4.11.6
    301 URL Tracker 1.5.2

  • Michael Nielsen 82 posts 361 karma points
    Apr 23, 2013 @ 12:55
    Michael Nielsen
    0

    No one with the same behaviour?

    When I rename pages, Automatic mappings are added, but these are also not working.

  • Dave Woestenborghs 3398 posts 11517 karma points MVP 6x admin c-trib
    Apr 23, 2013 @ 13:11
    Dave Woestenborghs
    100

    You should move the 301 Handler above the Ucomponents handlers.

    Dave

  • Mario 8 posts 58 karma points
    Apr 23, 2013 @ 14:32
    Mario
    0

    Hi, i have a similar problem. I have a clean installation in widows 2012 server whith sql server 2008. When i rename a document then create automatic mapping

    But when i try to access to old url always display page not found. (In classic mode)

    In Integrated mode:

    II have spent many hours searching the solution on the forum but i don't find the solution. 

    Thanks in advance.

  • Alex Skrypnyk 6054 posts 23213 karma points MVP 5x admin c-trib
    Apr 23, 2013 @ 15:17
    Alex Skrypnyk
    0

    Hi,

    Try to add to your web.config file )
     

     <system.webServer>
        <httpErrors existingResponse="PassThrough" />

     

    Thanks

  • Michael Nielsen 82 posts 361 karma points
    Apr 23, 2013 @ 15:28
    Michael Nielsen
    0

    Awesome... Thanks Dave... That worked...

    But it's weird because on other installtions it works fine with the previous config, but it works so I'm happy...

  • Mario 8 posts 58 karma points
    Apr 23, 2013 @ 15:58
    Mario
    0

    I have added

    <system.webServer>
       
    <httpErrorsexistingResponse="PassThrough"/>

    but the problem continues, now in Classic and Integrated mode display:

    My versions are:

    Umbraco 4.11.1
    301 URL Tracker 1.5.2

  • gpal 2 posts 22 karma points
    Apr 24, 2013 @ 13:21
    gpal
    0

    Hi there. I am very new user of 301 URL tracker and I am having some diffoculties.

    I am experiencing the same problem as above: the redirects give a Page not found error as shown in the above pictures.

    I have tired all the suggestions but i am still facing the same issue.

    Furthermore, I cannot see 301 URL tracker in the properties tab of a page. Again I ve tried all the suggested solutions but still cannot see them.

    I am using umbraco 4.5.2 and 301 URL tracker 1.3.

    I persume this version is compatible with umbraco 4.5.2 and i was wondering if any other available version is more suitable.

    thank you in advance

Please Sign in or register to post replies

Write your reply to:

Draft