Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Scott Reed 25 posts 69 karma points
    Aug 20, 2014 @ 12:19
    Scott Reed
    0

    Bundling

    Hi guys, I've installed this in Version 7.1 and everything is working fine however when debug is set to true it's still rendering the bundled version instead of the seperate script includes? Is there any other things that have to be done on 7+. Thanks for the help, p.s saw you at the Umbraco UK Conference, you have a nice helmet

  • Jeavon Leopold 3005 posts 13194 karma points MVP 7x admin c-trib
    Aug 20, 2014 @ 12:28
    Jeavon Leopold
    101

    You also need to edit "\App_Plugins\Optimus\Config\bundles.config" and set "ignoreCompilationDebug" to "False" and then restart your application for it to work.

  • Scott Reed 25 posts 69 karma points
    Aug 20, 2014 @ 14:21
    Scott Reed
    0

    Awesome thank you, working perfectly. Love the plugin :-)

  • Jeavon Leopold 3005 posts 13194 karma points MVP 7x admin c-trib
    Aug 20, 2014 @ 15:11
    Jeavon Leopold
    0

    You're welcome!

  • Scott Reed 25 posts 69 karma points
    Aug 20, 2014 @ 16:30
    Scott Reed
    0

    Can I bother you with one other question you might know? I've got a main page layout and on which I have @Scripts.Render("PATH") to all my main scripts. I was@RenderSection("scripts", required: false) area to render as standard all of the @Scripts.Render("PATH") references defined in page or partial views that are only required on that page but as they are not in sections what's the syntax for setting where the scripts should be included that have only been told to be included on specific views? This should be the last thing I'm confused on with Optimus, thanks for any help

  • Jeavon Leopold 3005 posts 13194 karma points MVP 7x admin c-trib
    Aug 20, 2014 @ 17:01
    Jeavon Leopold
    0

    I think if I have understood you right, you should just add a additionalScripts.Render in the specific view which has an additional bundle to render...?

  • Scott Reed 25 posts 69 karma points
    Aug 20, 2014 @ 17:58
    Scott Reed
    0

    Figured it out, I just needed a rendersection tag in the bottom of my page view and then have an @section for that area in the page. Then inside I could add the reference to the correct bundle, thanks for the help tho

Please Sign in or register to post replies

Write your reply to:

Draft