Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Oct 12, 2015 @ 12:45
    Tim Geyssens
    1

    YSOD on Umbraco 7.3

    Getting the following error message on umbraco 7.3

    Attempt by security transparent method 'System.Web.Http.GlobalConfiguration.get_Configuration()' to access security critical type 'System.Web.Http.HttpConfiguration' failed.

    Anyone found a fix for it yet?

  • Lars-Erik Aabech 343 posts 1088 karma points MVP 4x c-trib
    Oct 12, 2015 @ 12:56
    Lars-Erik Aabech
    1

    Yep,

    Long story short: upgrade all ASP.NET MVC packages from nuget.

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Oct 12, 2015 @ 13:07
    Tim Geyssens
    0

    Ok that's also what I could find, will give it a try, thanks!

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Oct 13, 2015 @ 07:47
    Tim Geyssens
    2

    Ok for anyone else encountering this ysod on 7.3, the latest version of Optimus 1.4.0 works (for older umbraco versions please use 1.3.2)

  • Bjarne Fyrstenborg 1160 posts 3356 karma points MVP 4x c-trib
    Feb 22, 2016 @ 14:46
    Bjarne Fyrstenborg
    3

    I had a similar issue when upgrading from Umbraco 7.2.4 (with Optimus 1.3.2 installed) to Umbraco 7.4.1 .. so after copying the new files from 7.4.1 and merging files, I got the error mentioned here when refreshing the site and therefore I couldn't run the upgrade installation.

    I removed these files from /bin folder:

    • Optimus.dll
    • Optimus.Providers.Less.dll
    • Optimus.Trees.Stylesheets.dll
    • Optimus.V7.dll

    Next I could run the upgrade of Umbraco.

    Finally I installed Optimus Core 1.4.0 and in my case also re-installed less provider.

    /Bjarne

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Feb 22, 2016 @ 18:56
    Tim Geyssens
    0

    Thanks for sharing your steps @Bjarne , just make sure if you want to keep your bundles you don't overwrite the App_Plugins\Optimus\config\bundles.config (or make sure to backup and restore)

  • Bjarne Fyrstenborg 1160 posts 3356 karma points MVP 4x c-trib
    Feb 22, 2016 @ 19:24
    Bjarne Fyrstenborg
    0

    Okay, I didn't noticed if that has happened during install of Optimus Core 1.4.0 or less provider? ...

    But I can restore the config if that has happened.. will check tomorrow :)

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Feb 22, 2016 @ 19:25
    Tim Geyssens
    0

    :) yeah core will install a new config file so better check it!

    Enjoy the evening! Cheers, Tim

  • Bjarne Fyrstenborg 1160 posts 3356 karma points MVP 4x c-trib
    Feb 23, 2016 @ 08:37
    Bjarne Fyrstenborg
    0

    @Tim it seems it didn't overwrite the existing bundles.config

    So I still have the existing bundles...

    /Bjarne

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Feb 23, 2016 @ 08:39
    Tim Geyssens
    0

    Great :)

Please Sign in or register to post replies

Write your reply to:

Draft