Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nik 1321 posts 5662 karma points MVP 3x c-trib
    Sep 28, 2016 @ 12:52
    Nik
    0

    SCSS compilation failure - undefined method 'visit_method'

    Hi,

    I'm using Optimus with the Sass provider as an attempt to switch from using CSS to using SCSS for projects.

    However, I'm having an issue when my SCSS is compiling.

    undefined method `visit_method' for Sass::Tree::Visitors::Cssize::Bubble:Class

    More accurately, I've pulled in Bootstrap 3 in SCSS version from here:

    https://github.com/twbs/bootstrap-sass

    When I save the _bootstrap.scss file in the umbraco back office I get the above error. A bit of googling hasn't shed much light on it so I'm wondering if anyone here can?

    I don't know if the issue lies in the provider or in the scss it self.

    Other info:

    Umbraco - 7.5.3 + Fano starter kit Windows 7 VS 2015 IIS Express .Net 4.5.2

    Hope you guys can point me in the right direction.

    For reference: Bower was used to install the bootstrap package, gulp was used to move the SCSS files into the appropriate location for Umbraco to find them.

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Sep 28, 2016 @ 13:08
    Tim Geyssens
    0

    Hmm could it be that the scss provider needs an update? So running newer scss on an old provider that doesn't support part of the syntax?

  • Nik 1321 posts 5662 karma points MVP 3x c-trib
    Sep 28, 2016 @ 13:10
    Nik
    0

    If I was to install the latest version of :

    https://www.nuget.org/packages/BundleTransformer.SassAndScss/

    Would that stop your provider from working?

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Sep 28, 2016 @ 13:16
    Tim Geyssens
    0

    Hmm not sure, give it a try and let me know :)

  • Nik 1321 posts 5662 karma points MVP 3x c-trib
    Sep 28, 2016 @ 14:33
    Nik
    0

    Looks like I'm falling down a rabbit hole I'm afraid Tim.

    I tried just adding the lastest Bundle Transformer and respective core to my project. That failed horrifically with a load of reference exceptions, even though I couldn't find any references in the web config.

    Then I tried forking your project and upgrading it in there. Looks like it needed everything to be upgraded as I was getting MVC reference issues. So I upgraded all of your Umbraco references to the latest version.

    Now I'm just trying it in your Test site, and I'm getting a variety of null errors that seem to stem from the BundleTransformer code and references to LibSassHost.

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Sep 28, 2016 @ 14:36
    Tim Geyssens
    0

    Sorry to hear that, got some time Friday so can take a look then. Will report back with my findings then, cheers, Tim

  • Nik 1321 posts 5662 karma points MVP 3x c-trib
    Sep 28, 2016 @ 14:40
    Nik
    0

    Thanks Tim :-)

    I'll keep looking myself and see if I can find more info to help.

    Talking of which.... delving into the LibSassHost error I'm getting the following:

    The type initializer for '<Module>' threw an exception.
     -> Inner exception:   
        The C++ module failed to load while attempting to initialize the default appdomain.
         -> Inner exception:
              Unable to find assembly 'Umbraco.Core, Version=1.0.6092.24019, Culture=neutral, PublicKeyToken=null'.
    

    Which is strange to me as it's running within an Umbraco site with, from what I can see, that exact core DLL.

  • Andrey Taritsyn 1 post 71 karma points
    Mar 13, 2017 @ 17:57
  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Sep 30, 2016 @ 09:34
    Tim Geyssens
    0

    Hey Nik, mind providing me with the scss snippet that fails?

    Cheers, Tim

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Sep 30, 2016 @ 09:38
    Tim Geyssens
    0

    Ah ok you pulled in all the bootstrap scss so will also do that

  • Nik 1321 posts 5662 karma points MVP 3x c-trib
    Sep 30, 2016 @ 09:40
    Nik
    0

    Hi Tim,

    Yeah, that was the SCSS that I was trying to compile. I've not written my own yet, simply grabbed that and tried to compile it.

    Thanks

    :-)

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Sep 30, 2016 @ 10:17
    Tim Geyssens
    0

    Yup hitting the same error btw :) so investigating...

  • Tim Geyssens 6524 posts 15306 karma points MVP 2x c-trib
    Oct 20, 2016 @ 07:59
    Tim Geyssens
    0

    Seems other folks are also hitting the error, but haven't had the time to finish the upgrade yet...

Please Sign in or register to post replies

Write your reply to:

Draft