Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Abilash Ashok 59 posts 414 karma points
    Mar 20, 2017 @ 10:25
    Abilash Ashok
    0

    Cache issue in categories and tags lisitng

    Hello,

    I was customizing Articulate blog and noticed some caching issue with category listing and tags listing. Here is the quick summary.

    Let's say, I have 2 category URL:

    When I navigate to URL1 it shows blogpost coming under category: Technology, which is the expected behavior. Now, if I navigate to URL2 then instead of listing post from category: General, it shows the post from category: Technology. Now, If I wait for few minutes in URL1 and navigate to URL2 then URL2 lists posts from category: General.

    I tested the behavior in different browser and the result was same which concludes that this is related to Umbraco's/Articulate's internal cache. Can somebody drop some pointers on where needs to be looked-up to analyze and fix this issue?

    Any help will be appreciated.

    Thanks.

  • Abilash Ashok 59 posts 414 karma points
    Apr 03, 2017 @ 07:29
    Abilash Ashok
    0

    I even tried rebuilding indexes as metioned here https://our.umbraco.org/documentation/Reference/Common-Pitfalls/#rebuilding-indexes but that didn't helped either. Does anyone have any clue on why this is happening so?

  • Abilash Ashok 59 posts 414 karma points
    Apr 10, 2017 @ 12:24
    Abilash Ashok
    100

    As I suspected, issue was with caching. There are 2 methods in Articulate's UmbracoHelperExtensions.cs - GetContentByTag and GetContentByTags which has code-block as below:

    code-snippet

    I temporarily commented-out caching logic to make it working. This sounds weird, but it works.

    Thanks.

Please Sign in or register to post replies

Write your reply to:

Draft