Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Andy Butland 372 posts 2036 karma points MVP 4x c-trib
    Mar 28, 2016 @ 13:55
    Andy Butland
    1

    Working on version 8 with VS.Net 2013

    This post actually comes with a solution rather than being a question, but thought it was useful to share in case others are trying to do the same thing. Specifically I had a fork already for Umbraco where I've worked on various things in version 7 and previous and wanted to switch to the version 8 branch to maybe look at working on that. I've also got VS.Net 2013.

    Here's the steps I went through, problems encountered and solutions found...

    Checked out dev-v8, tried to load the solution. Most projects don't load with a message that .Net framework 4.6.1 is not available, offering the choice to switch to another version.

    But actually it was installed - confirmed by trying to download and install again and checking registry settings as described here.

    I tried installing the targeting pack, restarted VS.Net and Windows - but still had same problem. Looking at another project, noticed 4.6.1 still wasn't available as a target framework.

    Installed .Net 4.6.1 and the targeting pack again, but this time via a chocolatey script.

    This time, all looked OK - could see 4.6.1 as a target framework and the dev-v8 branch projects all loaded in Visual Studio. So can't really explain what I was missing the first time, but at least with this method you get everything you need to work on .Net 4.6+ with VS.Net 2013.

    Couldn't build though due to some new NuGet packages I didn't have, which didn't restore on build.

    Read of a trick to force this by removing everything from the /packages/ folder. In the Package Manager Console window this then pops up the message "Some NuGet packages are missing from this solution. Click to restore from your online package sources." message, which I could use.

    Then it all built.

    On running got some configuration errors, had to compare my web.config with web.Template.config and make a few updates

    Replace:

    <add name="UmbracoRoleProvider" type="umbraco.providers.members.UmbracoRoleProvider" />

    With:

    <add name="UmbracoRoleProvider" type="Umbraco.Web.Security.Providers.MembersRoleProvider" />

    And remove:

    <add name="UmbracoSiteMapProvider" type="umbraco.presentation.nodeFactory.UmbracoSiteMapProvider" defaultDescriptionAlias="description" securityTrimmingEnabled="true" />

    and <buildProviders>...</buildProviders>

    Then runs as expected, the installer kicks in and the back-office loads.

    Hope that's useful for anyone else looking to get going on this with the same set up as me.

    Andy

  • Shannon Deminick 1510 posts 5190 karma points hq
    Mar 28, 2016 @ 14:09
    Shannon Deminick
    0

    Thanks for the feedback Andy! Moving forward though there won't be any official support for building with vs 2013, it will only be 2015+ for v8. Vs 2015 is free for the community edition which will work. I'm surprised it worked in 2013 tbh but maybe that is part of the build issue you were seeing.

  • Andy Butland 372 posts 2036 karma points MVP 4x c-trib
    Mar 28, 2016 @ 14:38
    Andy Butland
    0

    I was wondering about that - if this hadn't worked would have been good excuse to upgrade! I assume that means utilising C#6 features will be considered OK to use going forward too?

  • Shannon Deminick 1510 posts 5190 karma points hq
    Mar 28, 2016 @ 14:39
    Shannon Deminick
    0

    Yup for v8+ it will be

  • Sebastiaan Janssen 4894 posts 14638 karma points MVP admin hq
    Mar 29, 2016 @ 07:47
    Sebastiaan Janssen
    0

    Am I correct in assuming you switched to the dev-v8 branch and attempted a build? Just asking because the web.Template.config seems up to date, which probably means you had an old web.config laying around (the UmbracoSiteMapProvider has been removed quite a while ago as far as I remember).

  • Andy Butland 372 posts 2036 karma points MVP 4x c-trib
    Mar 29, 2016 @ 08:00
    Andy Butland
    1

    You are. Yes, web.Template.config was fine, I just had an old web.config.

Please Sign in or register to post replies

Write your reply to:

Draft