Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Jesper Hauge 298 posts 486 karma points c-trib
    May 31, 2011 @ 11:58
    Jesper Hauge
    0

    Non aspx resources is redirected to login.aspx

    Hi all,

    I'm currently having a fight with a Umbraco 4.7 install that redirects all resources to login.aspx, ie. css-files, media-files script-files and so on.

    Site was originally 4.6.1, and has been upgraded to 4.7, allthough not by me. I already checked:

    - ACL's everything is fine here, also re-applied settings to subdirectories
    - Identity of app-pool - running "Network Service" as I want it to
    - app-pool settings
    - Authentication setup in web.config, it's configured as in a default install, but using a Custom membership provider.
    - web.config overall, cannot find any differences from example v4.7 web.config
    - Copied /umbraco and /umbraco_client to website again, overwriting existing files.
    - Server clock (was originally 2 hours off)

    Any ideas or suggestions will be much appreciated.

    Regards
    Jesper Hauge

  • Frost 70 posts 99 karma points
    Nov 18, 2011 @ 02:47
    Frost
    0

    Sounds like the same problem I'm looking at. Did you ever figure it out?

  • Damian Green 452 posts 1433 karma points
    Mar 15, 2012 @ 12:12
    Damian Green
    1

    Just though id chime in on this as had something very similar!

    Id extracted some CSS files from a zip and they we showing green in windows explorer.

    I could view, edit and save the files.

    The permissions were exactly the same as other css files in the same folder that were showing filenames in black.

    But everytime i tried to view the css within the browser I was redirected to the login screen for the site.

    Turns out its a windows thing id never seen before.  The green files means they are encrypted - slightly odd that i could view them however... but if you right click the file and go to properties, then advanced there is a tickbox for encrypt file and another for compress.  I unticked compress and voila! It worked.

    The filenames turned black and IIS served up the file.

    One other thing was the files were also blocked! When you view properties ensure the "unblock" button is not enabled. This often happens with files from zips such as help files etc!

    This one had me baffled for a good couple of hours! Never seen those options in windows before.

     

     

  • Damian Green 452 posts 1433 karma points
    Mar 15, 2012 @ 12:13
    Damian Green
    0

    Just to also add - The other tickbox for compress turns the filenames blue! So another one to watch out for maybe.

  • colin gray 16 posts 55 karma points
    Jun 06, 2014 @ 12:41
    colin gray
    0

    had the issue even after I got by site copied over via a non zip method.

    my sollution was Go ot IIS > Select your Project > "Authentication" > Anonymous Authentication" > Edit > select "Application pool identity"
    (instead of "Specific User". )

Please Sign in or register to post replies

Write your reply to:

Draft