Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • John C Scott 473 posts 1183 karma points
    Jul 24, 2011 @ 16:30
    John C Scott

    publish all children timeout

    I have a node with 1000+ children, when I try to publish all sub pages I get a timeout error after about 150 documents. Is there any solution to this anyone can suggest? Thank you.

  • Dirk De Grave 4541 posts 6021 karma points MVP 3x admin c-trib
    Jul 24, 2011 @ 18:31
    Dirk De Grave

    Have no real solution to your problem, but if you really need to republish these 1000+ nodes asap, I'd install Richard's excellent maintenance dashboard package which allows you to select a number of docs and publish those in bulk. (I've used it before and tend to do a 50 document publishes each time, making sure I don't run into timeouts.

    As said, not THE solution, but it would work...




  • Richard Soeteman 4035 posts 12842 karma points MVP
    Jul 25, 2011 @ 07:46
    Richard Soeteman

    Hi John,

    Go for Dirk's solution or increase the ExecutionTimeout setting in the web.config on the httpRuntime element as in the example below

    <httpRuntime requestValidationMode="2.0" maxRequestLength="512000" executionTimeout="99999999" />



  • John C Scott 473 posts 1183 karma points
    Jul 25, 2011 @ 18:18
    John C Scott

    That's a brilliant answer. No I'd not tried the maintenance dashboard before, what a very very useful thing. Thank you.

  • Thomas Dolberg 74 posts 95 karma points
    Nov 06, 2011 @ 01:01
    Thomas Dolberg

    Hi Richard


    I changed the executionTimeOut to what you suggested, and it solved the time out problem I had. Are there any problems having a very high executionTimeOut as you suggest on my production server (performance issues, hanging threads etc)?




Please Sign in or register to post replies

Write your reply to: