Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sheppe 43 posts 139 karma points
    Oct 08, 2012 @ 02:27
    Sheppe
    0

    Umbraco/Examine PDF Search/Index Error

    Hi there,

    I've followed all of the various posts here, as well as all of the instructions over at examine.codeplex.com/documentation, but I just can't get Examine to begin indexing the PDFs on my site. Here's the stacktrace that occurs when it tries to begin indexing:

    Error loading application startup handler: System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeInitializationException: The type initializer for 'Examine.ExamineManager' threw an exception. ---> System.Configuration.ConfigurationErrorsException: Value cannot be null.  Parameter name: indexSet on LuceneExamineIndexer provider has not been set in configuration and/or the IndexerData property has not been explicitly set (D:\Websites\rdco\config\ExamineSettings.config line 12) ---> System.ArgumentNullException: Value cannot be null.  Parameter name: indexSet on LuceneExamineIndexer provider has not been set in configuration and/or the IndexerData property has not been explicitly set     at Examine.LuceneEngine.Providers.LuceneIndexer.Initialize(String name, NameValueCollection config)     at UmbracoExamine.BaseUmbracoIndexer.Initialize(String name, NameValueCollection config)     at UmbracoExamine.UmbracoContentIndexer.Initialize(String name, NameValueCollection config)     at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)     --- End of inner exception stack trace ---     at System.Web.Configuration.ProvidersHelper.InstantiateProvider(ProviderSettings providerSettings, Type providerType)     at System.Web.Configuration.ProvidersHelper.InstantiateProviders(ProviderSettingsCollection configProviders, ProviderCollection providers, Type providerType)     at Examine.ExamineManager.LoadProviders()     at Examine.ExamineManager..ctor()     at Examine.ExamineManager..cctor()     --- End of inner exception stack trace ---     at Examine.ExamineManager.get_Instance()     at UmbracoExamine.UmbracoEventManager..ctor()     --- End of inner exception stack trace ---     at System.RuntimeTypeHandle.CreateInstance(RuntimeType type, Boolean publicOnly, Boolean noCheck, Boolean& canBeCached, RuntimeMethodHandleInternal& ctor, Boolean& bNeedSecurityCheck)     at System.RuntimeType.CreateInstanceSlow(Boolean publicOnly, Boolean skipCheckThis, Boolean fillCache)     at System.RuntimeType.CreateInstanceDefaultCtor(Boolean publicOnly, Boolean skipVisibilityChecks, Boolean skipCheckThis, Boolean fillCache)     at System.Activator.CreateInstance(Type type, Boolean nonPublic)     at System.Activator.CreateInstance(Type type)     at umbraco.businesslogic.ApplicationStartupHandler..cctor()

    I've tried specifically setting the IndexSet value in the index provider and search provider, but no luck.

    I'm just using the values specified in the codeplex documentation to get PDF indexing happening, so nothing out of the ordinary. And yes, I have the necessary PDF indexing DLL's in the bin folder.

    Thoughts?

  • Sheppe 43 posts 139 karma points
    Oct 12, 2012 @ 15:36
    Sheppe
    0

    Anyone?

  • Ismail Mayat 4511 posts 10056 karma points MVP 2x admin c-trib
    Oct 12, 2012 @ 15:39
    Ismail Mayat
    0

    Sheppe,

    What version of umbraco are you using? 

  • Sheppe 43 posts 139 karma points
    Oct 12, 2012 @ 18:02
    Sheppe
    0

    Hi Ismail,

    The issue began in 4.7.2, so as part of trying to get this sorted out I've upgraded to 4.9.0. Unfortunately, that didn't fix anything.

    Also, the server this is running on is Windows SBS 2003 with all service packs applied.

    Thanks,

    -Sheppe

  • Tom Fulton 2030 posts 4990 karma points c-trib
    Oct 12, 2012 @ 18:14
    Tom Fulton
    0

    Hi,

    Not sure if this helps, but I got the same error when attempting to setup Examine to index a custom table in an SQL database.  The error came when it tried to index a row that had a null value in one of the columns.  To fix I just replaced null values with an empty string/etc.  Not sure if there's a proper fix for this or not, or if it might be something similar in your situation.

    I found this out by downloading the Examine source and debugging.

    HTH,
    Tom 

  • Sheppe 43 posts 139 karma points
    Oct 12, 2012 @ 19:51
    Sheppe
    0

    I think the issue lies in this section of the stack trace:

    Parameter name: indexSet on LuceneExamineIndexer provider has not been setin configuration and/or the IndexerData property has not been explicitly set(D:\Websites\rdco\config\ExamineSettings.config line 12)--->

    It doesn't seem to be accepting the value that I've entered into the ExamineSettings.config file for indexing PDFs (line 12 is where I've entered the values as outlined in the UmbracoExamine documentation on Codeplex).

    -Sheppe

  • Ismail Mayat 4511 posts 10056 karma points MVP 2x admin c-trib
    Oct 15, 2012 @ 11:20
    Ismail Mayat
    0

    Sheppe,

    Can you download the latest version of examine from codeplex and use those dlls. I recall a similar issue which we fixed by deploying latest examine dlls

     

    Regards

     

    Ismail

  • Sheppe 43 posts 139 karma points
    Oct 20, 2012 @ 05:44
    Sheppe
    0

    Hi Ismail,

    Unfortunately putting the latest version in place didn't help. In fact, the latest version available for download from codeplex predates the version shipped with Umbraco 4.9.0.

    I've now tried to get this running on two separate servers with no luck. Do you have any other suggestions?

    Thanks,

    -Sheppe

  • Sheppe 43 posts 139 karma points
    Oct 21, 2012 @ 19:39
    Sheppe
    0

    The problem was that I was using the ExamineIndex.config and ExamineSettings.config files from Umbraco v4.7.1. I rebuilt them from the versions shipped with v4.9.0 and voila.

Please Sign in or register to post replies

Write your reply to:

Draft