Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chris Perks 32 posts 114 karma points
    Nov 12, 2012 @ 10:51
    Chris Perks
    0

    Site showing wrong language in navigation

    Hi,

    Periodically, one of our production websites shows the 'wrong' language in its navigation module.

    In the screenshot above:

    • The rest of the site is in English, as it should be
    • The header is in Russian, which was incorrect
    • Refreshing the page, the navigation was still in Russian
    • This was replicated on many browsers in different locations / networks.
    • All client caches were cleared.

    The only way we know to fix this is to recycle the IIS app pool - which is obviously a blind workaround. But we'd like to understand why this happens.

    Has anyone seen a similar issue? Any ideas where to go next to find what would be causing it?

     

    Thanks.

  • Jan Skovgaard 11244 posts 23437 karma points MVP 6x admin c-trib
    Nov 12, 2012 @ 19:30
    Jan Skovgaard
    0

    Hi Christofr

    What does our Umbrao setup look like? Is the hostname assigned the proper languahes? And what version of Umbraco are you running?

    Looking forward to hearing more details from you.

    /Jan

  • Stephen 767 posts 2264 karma points c-trib
    Nov 13, 2012 @ 08:58
    Stephen
    1

    Usually this is produced by the navigation module being rendered by a macro and the macro being cached and the cache not varying properly depending on the language. Strange that it happens "periodically" though, unless it is a low-trafic website?

  • Chris Perks 32 posts 114 karma points
    Nov 13, 2012 @ 17:20
    Chris Perks
    0

    Thanks both,

    Stephen - this was exactly the problem.

    We managed to replicate the problem by viewing the page immediately after a cache clear, in Russian. Subsequent loads of the same page in English still showed the Russian navigation.

    We've disabled caching on that macro and in our initial tests, the problem seems to have gone away.

    Is there any known workaround to this issue, or perhaps something we could tweak in our setup to still enable macro caching but not get he languages tangled?

     

    Thanks again, the responses are appreciated.

     

     

Please Sign in or register to post replies

Write your reply to:

Draft