Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Garret 50 posts 270 karma points
    Dec 10, 2012 @ 20:05
    Garret
    0

    Could not load type 'Umbraco.Web.UmbracoApplication'. running in Visual Studio

    Hi All,

    When running my 4.11.1 instance of umbraco in visual studio I get the following YSOD.
    Anyone any ideas?

    Kind regards,

    Garret

     

    Server Error in '/' Application.

    Parser Error

    Description: An error occurred during the parsing of a resource required to service this request. Please review the following specific parse error details and modify your source file appropriately.

    Parser Error Message: Could not load type 'Umbraco.Web.UmbracoApplication'.

    Source Error:

    Line 1:  <%@ Application Codebehind="Global.asax.cs" Inherits="Umbraco.Web.UmbracoApplication" Language="C#" %>
    


    Source File: /global.asax    Line: 1


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.17929

  • Yannick Smits 321 posts 718 karma points
    Dec 11, 2012 @ 15:36
    Yannick Smits
    1

    If you upgraded from a previous version make sure that app_global_asax.dll is removed as well as check if there are some other dll's present in your bin that are not in the 4.11.1 download and see if they can be deleted.

  • Ivan Thorsen 16 posts 57 karma points
    Dec 16, 2012 @ 20:55
    Ivan Thorsen
    101

    I deleted all the files* in the following folders

    • App_Browsers
    • App_Code
    • App_Data
    • App_Plugins
    • bin*
    • install
    • Umbraco*
    • umbraco_client*
    • Views*
    * I took a backup of all 3. party / installed package files and copied them back into the folders.
    I hope this will help you too!
  • osk 1 post 21 karma points
    Nov 22, 2014 @ 10:32
    osk
    0

    I have the same problem... I created a new empty ASP.NET Web Application using .NET Framework 4.5.1. Then I installed Umbraco thrue Package Manager Console using Install-Package UmbracoCms". I replaced Web.config.

    After installation is done and I press CTRL+F5 I get the same error. 

    So the solution is to delete all the files and blabla...? How is the support/work on Umbraco? I mean, if you even cant install Umbraco to a clean web site without errors and a problem like this hasnt been fixed on two years? 

  • Otto 9 posts 78 karma points
    Nov 09, 2015 @ 15:27
    Otto
    0

    Hi!

    I have got the same error, Anyone have found a solution for that? something in the bin folder (core)... No idea. I'm changing things a day and I didn't get nothing...

    Anyone?

    Regards!

  • unalavo1104 1 post 72 karma points
    Mar 15, 2016 @ 05:21
    unalavo1104
    1

    I think you set the name of project is "Umbraco". Just change name of project to another name and this bug will be fixed.

  • Gerard 3 posts 74 karma points
    Apr 08, 2018 @ 13:10
    Gerard
    0

    And don't forget to rename the assembly name in the project's properties too.

  • Nattanahel Alberto Chaves Moya 1 post 71 karma points
    Aug 08, 2018 @ 20:02
    Nattanahel Alberto Chaves Moya
    0

    Excellent, it worked for me.

  • Echo Train 13 posts 103 karma points
    Mar 14, 2016 @ 17:56
    Echo Train
    0

    We are frustrated by this, also, and yet to find anything that resolves the issue. Hard to understand how this could persist for over three years.

  • Rakesh Kumar 1 post 71 karma points
    Apr 07, 2016 @ 17:44
    Rakesh Kumar
    0

    Hi Dev Friends

    This problem can be solved by renaming you project name, if have set it to Umbraco.

    still have problem.

    select project node in solution explorer and right click and select properties , and change name of assembly and default namespace to something else

    solve problem

  • Urvish 252 posts 770 karma points
    Jul 08, 2016 @ 07:01
    Urvish
    0

    Another solution is to change the .Net framwwork of the project.

    I encountered the same problem while installing the Umbraco 7.2.5 , after that i change the framework to 4.5 and it worked.

    Hope it will help.

    Regards,

    Urvish Mandaliya

  • Nathan 2 posts 72 karma points
    Aug 06, 2016 @ 16:17
    Nathan
    0

    I get this error too while installing the Umbraco 7.4.3 in VS2012. I find a solution in this post. and I dig more, if your project already named 'Umbraco', just change Assembly name to another name that will solve this problem.

  • Aleksey Rogachev 1 post 71 karma points
    Oct 31, 2018 @ 09:06
    Aleksey Rogachev
    0

    Thx! It works for me!

  • Rushabh 2 posts 72 karma points
    Mar 07, 2019 @ 02:27
    Rushabh
    1

    Hey guys, if anyone having issue with this error on Umbraco 8 than please update your .Net framework to ASP.NET 4.7.2. Sorted for me at least.

    Upgrade to ASP.NET 4.7.2

Please Sign in or register to post replies

Write your reply to:

Draft