Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Almir Vereget 62 posts 130 karma points
    Dec 13, 2012 @ 11:52
    Almir Vereget
    1

    Backend not working

    So our server ran out of space on C disk. After some maintenance 3 of 6 umbraco installations are not working. This is the error we get when we try to login into backend. Front end is working fine. Umbraco version is 4.8.1. I tried to restart website no luck, restarted web server still no luck. Anyone know where to look at into this problem.

    Thanks!

     

    Value cannot be null.
    Parameter name: source

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.ArgumentNullException: Value cannot be null.
    Parameter name: source

    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.


    Stack Trace:

    [ArgumentNullException: Value cannot be null.
    Parameter name: source]
       System.Linq.Enumerable.SingleOrDefault(IEnumerable`1 source, Func`2 predicate) +4472614
       umbraco.BusinessLogic.User.GetApplications() +403
       umbraco.cms.presentation._umbraco.Page_Load(Object sender, EventArgs e) +64
       System.Web.Util.CalliHelper.EventArgFunctionCaller(IntPtr fp, Object o, Object t, EventArgs e) +25
       umbraco.BasePages.BasePage.OnLoad(EventArgs e) +19
       System.Web.UI.Control.LoadRecursive() +71
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3064
    



    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.272

  • Almir Vereget 62 posts 130 karma points
    Dec 13, 2012 @ 12:07
    Almir Vereget
    3

    OK, found the problem. applications.config and trees.config were empty, obviously umbraco tried to create them but there were no space on disk and failed. I restored them from backup so everything works fine now.

  • colin gray 16 posts 56 karma points
    Feb 15, 2013 @ 14:26
    colin gray
    0

    same issue / same fix / different cause

    web Backend not working at all, same issue but not because of lack of disk space. Shared hosting, Umb 4.9.0

    found  config/applications.config and config/trees.config to have no content. copied files from another site. Thanks for the fix.

    Backend worked again...

  • Anthony Candaele 1197 posts 2049 karma points
    Apr 22, 2013 @ 14:14
    Anthony Candaele
    0

    had the same issue. Copying the applications.config file from a backup saved my day.

    Thanks a lot Almir

  • Ali Sheikh Taheri 470 posts 1647 karma points c-trib
    Jun 17, 2013 @ 00:35
    Ali Sheikh Taheri
    0

    Thanks Almir, I had exactly the same issue. restored the applications.config and trees.config from git and it works like a charm.

    Cheers

    Ali

  • jacob phillips 130 posts 372 karma points
    May 05, 2014 @ 21:17
    jacob phillips
    0

    Same issue. Thx.

  • Karl Alesbury 2 posts 22 karma points
    Dec 22, 2017 @ 12:54
    Karl Alesbury
    0

    And same for me too! Thanks for the heads-up. Wouldn't have thought to look there.

Please Sign in or register to post replies

Write your reply to:

Draft