Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Steve Temple 54 posts 288 karma points MVP c-trib
    Apr 08, 2013 @ 16:02
    Steve Temple
    0

    Publish not working with distributedCall

    Hi,

    I'm having an issue with a site where the publish isn't doing anything with distributed call setup.

    The site is running in a virtual directory so should I use the hostname only of each server or include the virtual directory? Is there anything else I need to setup?

    This:

    <distributedCall enable="true">
    <user>0</user>
    <servers>
    <server>server1.url</server>
    <server>server2.url</server>
    </servers>
    </distributedCall>

    or this:

    <distributedCall enable="true">
    <user>0</user>
    <servers>
    <server>server1.url/directory1/directory2/</server>
    <server>server2.url/directory1/directory2/</server>
    </servers>
    </distributedCall>

    Thanks in advance for your help

    Steve

  • Steve Temple 54 posts 288 karma points MVP c-trib
    Apr 09, 2013 @ 00:40
    Steve Temple
    100

    Ok, I've just setup a test environment and I can say that you don't need to put the directory structure in, 

    Hope that helps

    Steve

  • Dhiren 58 posts 198 karma points
    Feb 06, 2015 @ 10:03
    Dhiren
    0

    Hi,

    We are facing same issue. Our servers are accessible through each other. Also settings for server is correct. But still publish is not working.

    Thanks,
    Dhiren 

  • Razvan Trifan 7 posts 78 karma points
    Aug 21, 2015 @ 00:10
    Razvan Trifan
    0

    Hi Dhiren,

    Have you found a solution to this? I'm experiencing the same issue. Here's my configuration for the Azure Virtual Servers:

    <distributedCall enable="true">
    <user>0</user>
    <servers>
      <servers>
        <server forcePortnumber="MyAzurePrivatePortNumber" forceProtocol="http" serverName="MyAzureWebServer1">10.0.1.XX</server>
        <server forcePortnumber="MyAzurePrivatePortNumber" forceProtocol="http" serverName="MyAzureWebServer2">10.0.1.YY</server>
      </servers>
    </servers>
    

    10.0.1.XX and 10.0.1.YY are private IPs and the 2 web servers can access each other. I can't see any calls being made in the Umbraco trace log or in the IIS logs.

    I am running Umbraco 6.1.6, Windows Server 2012 R2, IIS 8.5 and DFS replication. The umbraco.config file is not replicated.

    Thanks, Razvan

  • Dave Woestenborghs 3217 posts 10834 karma points MVP 4x admin c-trib
    Aug 21, 2015 @ 06:51
    Dave Woestenborghs
    0

    Hi all,

    I have a similar issue as well.

    The serverName attribute must match the actual machine name.

    See this post for more information : https://our.umbraco.org/forum/core/general/63695-Scheduled-tasks-not-working-in-load-balanced-environment

    Dave

  • Razvan Trifan 7 posts 78 karma points
    Aug 21, 2015 @ 07:34
    Razvan Trifan
    0

    Hi Dave,

    Thanks for getting back to me. The serverName matches the machine name for both servers. The websites are accessibile from one server to another and I tried using both the IP + port and adding custom host names in the .hosts file. That had no effect at all and nothing shows up in the logs.

    Thanks, Razvan

Please Sign in or register to post replies

Write your reply to:

Draft