Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Scott Robinson 54 posts 75 karma points
    Jun 24, 2013 @ 12:07
    Scott Robinson
    0

    Admin password not working after uComponents package install..

    Hi,

    Does anyone know a simple solution to this issue?

    I was thrown out of Umbraco 6.06 midway (I assume) through installing uCompoennts. The result is that my admin U/P no longer works. What am I supposed to do? Every day I'm working on Umbraco it seems I'm having to fix something that breaks. The challenge is getting a bit tiring on a Monday morning :)

     

    Thanks for any help


    Scott

  • Hendy Racher 863 posts 3847 karma points MVP 2x admin c-trib
    Jun 24, 2013 @ 12:28
    Hendy Racher
    0

    Hi Scott,

    Difficult to tell what went wrong there, can you access the database ? are there any error logs ? did you install a custom uComponents 6.x build ? (there's a compatability grid here: https://ucomponents.codeplex.com/ - )

    Cheers,

    Hendy

  • Scott Robinson 54 posts 75 karma points
    Jun 24, 2013 @ 12:36
    Scott Robinson
    0

    I installed the package on the Package center as it said it was 6 compatible. I perhaps should have check the specific build. But assuming the build is 5.x on the center then it should be compatible. I have database access. Anything in particular I should look for? I found this article:

     

    http://our.umbraco.org/forum/using/ui-questions/4790-ouch-forgot-admin-password-how-to-reset

     

    And I guess I will try and alter the admin password directly within the database, unless anyone has any better options?

     

    Thaks :)

  • jigar 170 posts 233 karma points
    Jun 24, 2013 @ 12:52
    jigar
    1

    If still you are not able to logged in as admin try doing following.

    1. Find " <!-- Membership Provider >" section in web.config and change the passwordFormat from "Hashed" to "Clear"
    2. After that run the following command in sql after selecting your database.

      UPDATE umbracoUser set userdisabled=0, userLogin='admin', userPassword='default' where id=0

    3. This will set your main admin user login as "admin" and password  as "default".

    Using the above will help you to login in to admin site.

  • Scott Robinson 54 posts 75 karma points
    Jun 24, 2013 @ 13:17
    Scott Robinson
    0

    Okay that was very stressfull. I though it hadn't worked but notice 2 lines in the web.config: UmbracoMembershipProvider & UsersMembershipProvider.

    I think I change the wrong one with no result. I have backend access now.

     

    Thank you o much for your help

     

    Scott

  • jigar 170 posts 233 karma points
    Jun 24, 2013 @ 13:20
    jigar
    0

    Glade it helped... Thanks for the High-Five.

  • Scott Robinson 54 posts 75 karma points
    Jun 24, 2013 @ 15:23
    Scott Robinson
    0

    Hmmm ...... After an hour of working. I am getting the same probelm. My passwords are set to "Clear" and I edited the DB a number of time with different creds, but I am locked outof the backend.

    Any other ideas?

     

    Scott

  • Scott Robinson 54 posts 75 karma points
    Jun 24, 2013 @ 15:32
    Scott Robinson
    0

    This is too wierd. If I change the DB settings back to admin and default it works. For some reason it's not reading the recent DB changes. I know azure sometimes has a problem with caching so I restarted as a precaution. I'm a little concerned now that I'm working on a flaky system. I think I'll set up a new "unique" user. Would I set up first and them change the web.config back to "hashed"?

  • jigar 170 posts 233 karma points
    Jun 24, 2013 @ 16:02
    jigar
    0

    No if you put it back to hashed it will not work.... See by changing the format to be clear your are telling the environment to check against non encrypted password version. So please keep it as is.

    Also if possiable keep it clear for some time then get a hash version of known password and then set it.

Please Sign in or register to post replies

Write your reply to:

Draft