Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Paul Stoker 39 posts 72 karma points c-trib
    Jan 30, 2014 @ 13:00
    Paul Stoker
    0

    Content could not be published because of invalid properties

     

    After upgrading from Umbraco 4.7.2 to 6.1.6 I have the following issue on one particular node.

    2014-01-30 10:31:12,565 [11] INFO  Umbraco.Core.Services.ContentService - [Thread 22] Content 'Homepage' with Id '1163' could not be published because of invalid properties
    Content 'Homepage' with Id '1163' will not be published because some of it's content is not passing validation rules.

    I found a similar question here below but the answer doesnt say how he fixed the issue.

    http://our.umbraco.org/forum/ourumb-dev-forum/bugs/38012-v6000-Can-not-be-published-because-of-invalid-properties

    I have also followed the guide below and tried recreating the page but I'm still receving errors 

    http://our.umbraco.org/wiki/how-tos/fix-odd-publishing-problems

    Can anyone help? I believe its a problem with the Document type but is there any other way of correcting this without recreating it as there are quite a few fields to re-enter.

    I have checked the validation and mandatory fields for each of the Document type properties and none of them are set.

     

  • Paul Stoker 39 posts 72 karma points c-trib
    Jan 30, 2014 @ 14:09
    Paul Stoker
    0

    To answer my own question, I too found that there was an issue with one of the description on a property type inside of the Homepage Document Type.

    Performing these steps fixed it:

    1. Open document type
    2. Expand property
    3. Remove description
    4. Save document type
    5. Save and Publish Node
    Repeat the above for each property in the document type until the node saves correctly.
    EDIT
    After checking again, I realised the text for a description somehow ended up in the validation field instead therefore this is what I fixed. I think the above is still valid to locate the cause though.
  • Matt Parkinson 12 posts 64 karma points
    Feb 10, 2014 @ 16:01
    Matt Parkinson
    0

    Thanks for the above info, this helped solve the same problem.

    I used the below SQL statement to double check if any other items were incorrect:

    SELECT * FROM [database name].[dbo].[cmsPropertyType]
    where [validationRegExp] is not null
    
  • Lee 26 posts 74 karma points
    Aug 25, 2014 @ 22:30
    Lee
    0

    I got this error when creating content programmatically.  It was due to an inherited property (from my Base doc type) that was of type 'True/false' and 'Mandatory'.  It seemed like an issue to me, so I reported it.

    http://issues.umbraco.org/issue/U4-5398

  • Robert Mulder 79 posts 269 karma points c-trib
    Apr 07, 2015 @ 09:58
    Robert Mulder
    1

    Also note that you can get this error if you try to publish a page that has an "Unpublish at" date set in the past. The logs wil give a better error, but for the end user it can be very confusing.

  • Garrett Fisher 341 posts 496 karma points
    Aug 27, 2015 @ 18:43
    Garrett Fisher
    0

    NICE one, man -- thanks for this -- you are bang-on: at some point b/t 4.7.2 and 6.2.5 a bunch of whitespace appears in the validationRegExp field. All that need be done is to remove it.

    Regards, Garrett

  • Arjan 21 posts 91 karma points
    Feb 12, 2016 @ 11:51
    Arjan
    0

    Note that you also (incorrectly) get this error in 7.3.4 back office when attempting to publish a page from the trash. However, the correct error is in the trace log.

    Publishing an item from the trash may sound strange, but it is quite possible to happen to you, because the default search config includes results from the trash, and when opening a trashed page, 7.3.4 back office doesn't show it's Trashed ;)

  • Murray Roke 453 posts 840 karma points c-trib
    Apr 26, 2016 @ 04:53
    Murray Roke
    0

    Also copying a page from the trash then trying to publish produces a similar error. I've reported here:

    http://issues.umbraco.org/issue/U4-8374

Please Sign in or register to post replies

Write your reply to:

Draft