Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Javier Barrera 34 posts 85 karma points
    Apr 28, 2014 @ 19:19
    Javier Barrera
    0

    Error Upgrading Umbraco 6.1.2 to 6.2.0.1-RC

    I performed a NuGet upgrade using the command "Update-Package UmbracoCms -Version 6.2.0.1-RC -Pre"

    I followed the general upgrade guidelines (http://our.umbraco.org/documentation/Installation/Upgrading/general) and did a compare of my /config files and web.config using WinMerge. I can compile my solution and run.

    However, during the upgrade process, I get to "Upgrading Umbraco" where it only gets to 5%. Looking at my network console, I see that Umbraco makes a call to /install/InstallerRestService.aspx/InstallOrUpgrade where it gets the error message:

    Unknown web method InstallOrUpgrade. Parameter name: methodName

    I reverted back to my original source, and tried the NuGet upgrade again with the same results. Is there anything I possibly missed moving over or accidently overriding in the /config or web.config files that would be causing this? My project is set to .NET 4.0.

  • Torleif 11 posts 68 karma points
    May 08, 2014 @ 17:32
    Torleif
    0

    I am having the exact same problem. Did you find any solution Javier?

  • Javier Barrera 34 posts 85 karma points
    May 08, 2014 @ 17:48
    Javier Barrera
    0

    Unfortuantely I still haven't found a solution.

  • Jan Skovgaard 11264 posts 23592 karma points MVP 8x admin c-trib
    May 08, 2014 @ 19:15
    Jan Skovgaard
    0

    Hi guys

    What database are you using?

    And what is your setup? Is it locally that it fails or on a server?

    /Jan

  • Javier Barrera 34 posts 85 karma points
    May 08, 2014 @ 19:19
    Javier Barrera
    0

    We replicated our old database on SQL Server 2012 and LocalDB. We tried both databases without success. We are doing local development as an MVC Web Application Project. Our target framework is .NET 4.5 with processor targeting to be "Any."

  • Torleif 11 posts 68 karma points
    May 08, 2014 @ 20:12
    Torleif
    0

    I am are using  SQL Server 2008 R2 on a external server. The application is running locally.

     

    This is output from UmbracoTraceLog:

    2014-05-08 20:18:13,638 [13] ERROR Umbraco.Core.UmbracoApplicationBase - [Thread 10] An unhandled exception occurred

    System.ArgumentException: Unknown web method InstallOrUpgrade.

    Parameter name: methodName

       at System.Web.Handlers.ScriptModule.OnPostAcquireRequestState(Object sender, EventArgs eventArgs)

       at System.Web.HttpApplication.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute()

       at System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) 

  • Ben 2 posts 22 karma points
    May 10, 2014 @ 08:54
    Ben
    0

    I had the same issue so I thought I'd try running my database against the source code (with my old version & database connection string in web.config) to see if I could catch the error. Both fortunately and unfortunately however that resulted in the database upgrading correctly, so not sure what exactly was preventing the issue in my initial configuration but upgrading your database in a different fresh install is one way around the issue.

    Worth noting was running a SQL 2012 database and like the others running the code locally through Visual Studio.

  • Patrik Näsfors 1 post 21 karma points
    May 26, 2014 @ 16:23
    Patrik Näsfors
    0

    Hi, I also had this problem, but found a quite easy solution. It was the first time ever I should upgrade an Umbraco installation, but since the Umbraco developers left us - I had to do it. I was quite disappoined how complicated it was to make a "simple" upgrade, from 6.1.6 to 6.2.0 - copying files and merging filer MANUALLY. What a disaster for a modern program/system. :-(

    But when I finally had did that and entered the upgrade process, it got stuck at 5 % when connecting to the database. After a while I found out that I hadn't copied the Install files (the Install folder from the zip-file) to the site.

    After I did that it completed fine.

    Hopefully this can help someone - and hopefull the upgrade process is (more) automatic the next time I'll upgrade. :-)

    Best regards,
    Patrik Näsfors

  • Raffaele 3 posts 47 karma points
    Jun 13, 2014 @ 16:33
    Raffaele
    3

    You're right Patrik: that's why the installer is not working.

    I've upgraded umbraco from 6.1.6 to 6.2.1 using Nuget, and I had the same issue: Nuget didn't upgrade the "install" folder.

    (You get the error message because, there is no InstallOrUpgrade method in the upgraded version: there are two methods called Install and Upgrade.)

    If you use Nuget you'll have to manually copy-paste the install folder http://our.umbraco.org/ReleaseDownload?id=125631 in your project.

     

  • Zac 223 posts 575 karma points
    Feb 01, 2015 @ 18:24
    Zac
    0

    +1

    Nuget didn't upgrade my install folder either and I got the same error message.

Please Sign in or register to post replies

Write your reply to:

Draft