Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Fuji Kusaka 2203 posts 4220 karma points
    Aug 03, 2014 @ 15:22
    Fuji Kusaka
    0

    301-url-tracker installer

    Hi guys,

    After installing 301-url tracker package on an old umbraco v 4.11.8 i cant access the back end anyone.

    Could not load type 'Umbraco.Web.UI.Pages.UmbracoEnsuredPage' from assembly 'umbraco, Version=1.0.4869.17901, Culture=neutral, PublicKeyToken=null'.

    [TypeLoadException: Could not load type 'Umbraco.Web.UI.Pages.UmbracoEnsuredPage' from assembly 'umbraco, Version=1.0.4869.17901, Culture=neutral, PublicKeyToken=null'.]
       System.Reflection.RuntimeAssembly.GetExportedTypes(RuntimeAssembly assembly, ObjectHandleOnStack retTypes) +0
       System.Reflection.RuntimeAssembly.GetExportedTypes() +49
       Umbraco.Core.TypeFinder.GetTypesWithFormattedException(Assembly a) +95
       Umbraco.Core.TypeFinder.GetTypes(Type assignTypeFrom, IEnumerable`1 assemblies, Boolean onlyConcreteClasses) +161
       umbraco.BusinessLogic.Actions.Action.<ReRegisterActionsAndHandlers>b__1() +62
       Umbraco.Core.ObjectResolution.LazyManyObjectsResolverBase`2.<get_InstanceTypes>b__5(Func`1 x) +11
       System.Linq.<SelectManyIterator>d__14`2.MoveNext() +267
       System.Linq.Buffer`1..ctor(IEnumerable`1 source) +520
       System.Linq.Enumerable.ToArray(IEnumerable`1 source) +103
       Umbraco.Core.ObjectResolution.LazyManyObjectsResolverBase`2.get_InstanceTypes() +623
       Umbraco.Core.ActionsResolver.CreateInstances() +102
       Umbraco.Core.ObjectResolution.ManyObjectsResolverBase`2.get_Values() +667
       umbraco.BusinessLogic.Actions.Action.GetJavaScriptFileReferences() +29
       umbraco.cms.presentation._umbraco.RenderActionJS() +83
       umbraco.cms.presentation._umbraco.Page_Load(Object sender, EventArgs e) +1706
       umbraco.BasePages.BasePage.OnLoad(EventArgs e) +19
       System.Web.UI.Control.LoadRecursive() +71
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +3178

     

    How do i get to uninstall the package and get access back to the back end ?

    Thanks,


  • Fuji Kusaka 2203 posts 4220 karma points
    Aug 04, 2014 @ 17:36
    Fuji Kusaka
    0

    Any suggestion how to remove this package and get access to the back end again ?

  • Fuji Kusaka 2203 posts 4220 karma points
    Aug 04, 2014 @ 20:25
    Fuji Kusaka
    1

    Removing the InfoCaster.Umbraco.UrlTracker.dll and  InfoCaster.Umbraco.UrlTracker.pdb worked here. 

    Hope this didnt affect any other file in my umbraco instance now.

  • lonehorseend 24 posts 71 karma points
    Dec 10, 2014 @ 02:36
    lonehorseend
    0

    Had the same problem with a 6.0.5 site. Thanks for your suggestion.

  • Barry 7 posts 94 karma points MVP c-trib
    Jun 04, 2015 @ 08:00
    Barry
    0

    That worked for me to, thanks!

    Any idea if it is possible to get that package working when this happens?

  • Marc Ferrold 24 posts 105 karma points
    Sep 11, 2015 @ 08:09
    Marc Ferrold
    0

    Having somewhat the same error, but removing those files didn't help much - still get a load error when trying to view content now, and I can't rebuild indexes with the External Indexer (Get error 409: Could Not Rebuild). The "URL Tracker" tab in the content section is also still visible. Can't seem to get rid of this and I've let it ruin a project if I can't save it.

  • stephen 75 posts 116 karma points
    Sep 24, 2015 @ 12:55
    stephen
    0

    Anything documenting why this error and if it was resolved?

    An old v4.11 and tried 3.7,3.8 and 3.9

  • Marc Ferrold 24 posts 105 karma points
    Sep 24, 2015 @ 12:59
    Marc Ferrold
    0

    Sadly, I do not know what caused the error nor if it has been addressed - I had to reboot the app pool before I could rebuild my site's indexes. There's still a URL Tracker tab in the backend, but it is empty.

Please Sign in or register to post replies

Write your reply to:

Draft