Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon steed 350 posts 615 karma points
    Sep 09, 2014 @ 11:55
    Simon steed
    0

    Worrying errors in the logs over last couple of days from Umbraco.Web.Scheduling.ScheduledPublishing

    Umbraco 6.2.2 recent upgrade from 6.2.1 to fix other issues in core.

    Suddenly in the last 24 hours started to see the following errors coming in the umbracotracelog.txt file. Not a clue why and was not happening last week. This is not a distributed site nor using load balancing (other posts with similar errors mention these).

    There was a scheduled task to call a page every 60 seconds but even when that is disabled, the errors still occur.

    2014-09-09 10:29:10,563 [19] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 31] An error occurred with the scheduled publishing System.Net.WebException: The remote server returned an error: (500) Internal Server Error. at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request) at System.Net.WebClient.UploadString(Uri address, String method, String data) at System.Net.WebClient.UploadString(String address, String data) at Umbraco.Web.Scheduling.ScheduledPublishing.Start(ApplicationContext appContext)

    2014-09-09 10:33:17,760 [13] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 14] An error occurred with the scheduled publishing
    System.Net.WebException: The operation has timed out
       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
       at System.Net.WebClient.UploadString(Uri address, String method, String data)
       at System.Net.WebClient.UploadString(String address, String data)
       at Umbraco.Web.Scheduling.ScheduledPublishing.Start(ApplicationContext appContext)
    2014-09-09 10:33:34,117 [13] ERROR Umbraco.Web.Scheduling.KeepAlive - [Thread 15] Error in ping
    System.Net.WebException: The operation has timed out
       at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)
       at System.Net.WebClient.DownloadString(Uri address)
       at System.Net.WebClient.DownloadString(String address)
       at Umbraco.Web.Scheduling.KeepAlive.Start(Object sender)
    2014-09-09 10:35:04,119 [13] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 8] An error occurred with the scheduled publishing
    System.Net.WebException: The operation has timed out
       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
       at System.Net.WebClient.UploadString(Uri address, String method, String data)
       at System.Net.WebClient.UploadString(String address, String data)
       at Umbraco.Web.Scheduling.ScheduledPublishing.Start(ApplicationContext appContext)
    2014-09-09 10:37:04,124 [13] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 33] An error occurred with the scheduled publishing
    System.Net.WebException: The operation has timed out
       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
       at System.Net.WebClient.UploadString(Uri address, String method, String data)
       at System.Net.WebClient.UploadString(String address, String data)
       at Umbraco.Web.Scheduling.ScheduledPublishing.Start(ApplicationContext appContext)
  • Simon steed 350 posts 615 karma points
    Sep 16, 2014 @ 09:54
    Simon steed
    0

    Still getting these errors, anyone any ideas?

  • Damiaan 408 posts 1172 karma points MVP c-trib
    Sep 16, 2014 @ 10:01
    Damiaan
    0

    Are you using loadbalancing? Have you tasks configured in the umbracosettings.config?

  • Simon steed 350 posts 615 karma points
    Sep 16, 2014 @ 10:25
    Simon steed
    0

    Nope no load balancing and there is one task in the config - however when this is disabled, we still get the errors.

  • Damiaan 408 posts 1172 karma points MVP c-trib
    Sep 16, 2014 @ 10:31
    Damiaan
    0

    You are not the only one: http://issues.umbraco.org/issue/U4-4159

    Dan Diplo seems to have a solution in this post.

  • Simon steed 350 posts 615 karma points
    Sep 16, 2014 @ 11:48
    Simon steed
    0

    Similar but not the same errors however could be related i guess - waiting for HQ to come back to me as well.

  • Matt 10 posts 70 karma points
    Sep 23, 2014 @ 03:26
    Matt
    0

    Any word?  I've got the exact same error happening every minute since upgrading to 6.2.2...

  • Simon steed 350 posts 615 karma points
    Sep 23, 2014 @ 09:38
    Simon steed
    0

    Not yet but Paul Sterling asked me to disable all the scheduled tasks in the umbraco settings file and check - I have tried that previously but it still happened but going to try again properly today

  • Steve Morgan 977 posts 3014 karma points c-trib
    Sep 24, 2014 @ 19:48
    Steve Morgan
    0

    Hi Simon,

    Just been scratching my head about this very issue. I have a client in pre-golive and this was filling their logs every minute. Turns out it's because I've put IP / Address filtering on IIS to stop Google et al finding the site prematurely... this has the side effect of blocking the scheduler from call itself on the server.

    I've tried to find the correct IPv6 local IP to add to the execptions but it doesn't work. Guess I'll live with it until it goes live. 

    Wonder if that is your issue?

    Steve

  • Steve Morgan 977 posts 3014 karma points c-trib
    Sep 24, 2014 @ 19:49
    Steve Morgan
    0

    PS I should note I'm on v7.1.6 so it might be very different.

  • marcelh 170 posts 470 karma points
    Oct 02, 2014 @ 12:45
    marcelh
    0

    Ah, it's only now noted I submitted a post with a similar issue. Have you resolved this?

  • Simon steed 350 posts 615 karma points
    Oct 17, 2014 @ 23:22
    Simon steed
    0

    Nope still happening and cannot get to the bottom of it!

  • Jan Skovgaard 11143 posts 22746 karma points MVP 4x admin c-trib
    Oct 18, 2014 @ 08:55
    Jan Skovgaard
    0

    Hi Simon

    Have you written to support about this? You are a gold partner right? Then it might be worth a shot to get in touch with the guys directly if you have not done so already :)

    /Jan

  • Simon steed 350 posts 615 karma points
    Oct 18, 2014 @ 10:10
    Simon steed
    0

    Certainly have, tried what they suggested but to no avail. Next steps are for me to download the source, rebuild against the project and trace the bloody thing through myself :(

  • marcelh 170 posts 470 karma points
    Oct 18, 2014 @ 10:19
    marcelh
    0

    I noticed my issue was due to IIS redirecting traffic to HTTPS using URL rewriting. Without the rewrite rules, both the KeepAlive and Scheduling pages are called succesfully.

    The funny thing though is that both URL's are opened with a System.Net.WebClient. When I use that to open connections to both the URL's all is fine. From within Umbraco they fail with a "The underlying connection was closed" message. This is different from your "The operation has timed out" however.

  • Ian Black 54 posts 230 karma points
    Oct 30, 2014 @ 13:30
    Ian Black
    0

    I too am having the same issue although removing my HTTPS rewrites still doesn't seem to stop the errors:

    http://our.umbraco.org/forum/umbraco-7/using-umbraco-7/57083-Error-with-SheduledPublishing,-underlying-connection-was-closed?p=0#comment197061

  • Sebastiaan Janssen 4664 posts 13046 karma points MVP admin hq
    Nov 03, 2014 @ 22:28
    Sebastiaan Janssen
    0

    So we've been battling with the same errors in the logs for the past week and we've nailed it down to (in our setup at least) a continuous cycle of the site creating new app domains resulting in very poor performance on the sites themselves.

    I'm adding what we found in the hope that it might confirm that you're having the same issue, this shouldn't be considered the "official" answer to the support case opened by Simon as we have no clear indication that this is the underlying issue. :-)

    So, eventually what we found is that our sites kept creating new app domains for some strange reason. We haven't yet figured out why at all and that might take a while but the workaround we found is the following: http://stackoverflow.com/a/17645687/5018
    What we've been doing is adding <httpRuntime fcnMode="Disabled" /> to the affected sites. Notice that this has some interesting side-effects and we don't know all of them yet, but one of them is that saving a .cshtml file will not automatically refresh the logic behind it, you HAVE to recycle the app pool/touch the web.config to make the changes have effect in the environment that fcnMode is disabled. So no more quick changes on the live site through the backoffice, you have to recycle. Other side-effects we don't know much about yet.

    Note that the sites that had this problem in our case were using some classes in the App_Code folder, not sure if that is a contributing factor to the problem.

    Again, I'm just sharing this information to see if it can help in your currently deployed sites and I would love to hear if the setups are similar so we can track down the actual source of the problem.

    We have added some changes to 7.2.0 to at least not try to call non-existing URLs but I'd really like to make sure we're not just hiding the problem here. See issue: http://issues.umbraco.org/issue/U4-5728

  • Braydie 148 posts 346 karma points
    Nov 06, 2014 @ 12:59
    Braydie
    0

    We're currently in the process of upgrading a site from 6.1.6 to 6.2.4 and we are now seeing this issue. We've seen poor performance when attempting to configure our site to be load balanced and do not have any code running from App_Code.

    In addition to the performance problems, we are seeing are errors being logged from the keepalive service, ping and scheduled publishing service. On top of that we can't seem to get published content to appear on both web servers - i.e. Publish on one web server and the changes are not appearing on the second web server, this extends to examine indices as well.

    Just having a poke around now and have found there does seem to be issues with Umbraco 6.2.X and 7.1.X with regards to running in a load balanced environment, I wonder if these are all related in some way:

  • Sebastiaan Janssen 4664 posts 13046 karma points MVP admin hq
    Nov 06, 2014 @ 16:22
    Sebastiaan Janssen
    0

    Does adding <httpRuntime fcnMode="Disabled" /> to your site help at all? (question goes for everybody in this thread, by the way)

    We are not running any load balanced sites but if they're not appropriately configured then I'm sure this could be a side effect.
    Make sure to follow the documentation precisely: http://our.umbraco.org/documentation/Installation/load-balancing

  • Matthias Bier 30 posts 90 karma points
    Nov 06, 2014 @ 16:31
    Matthias Bier
    0

    After adding

    <httpRuntime fcnMode="Disabled" />
    

    the error seems to be gone. Error was:

    ERROR Umbraco.Web.Scheduling.KeepAlive - [Thread 55] Error in ping System.Net.WebException: The operation has timed out...
    

    Also my hosting provider sent me an email today asking why my site took 60% CPU load and a lot of memory... Perhaps this explains it...

    Matthias

  • Sebastiaan Janssen 4664 posts 13046 karma points MVP admin hq
    Nov 06, 2014 @ 18:30
    Sebastiaan Janssen
    0

    Yeah, we saw the same thing happening. My guess is that your hosting provider is using a SAN or something like that to host your files. Since Umbraco has quite a lot of files, they get scanned constantly (which can also cause higher load). My understanding is that disabling fcnMode will stop most of that scanning and will limit it to bin and web.config. Again, this means that if you DO do live edits on your razor (templates/views/macroscript) files then they will not reflect changes until you touch web.config.

    I've still not completely figured out what other impact this has so make sure to read up on fcnMode and be aware that you might get some strange results.

  • Richard Galt 50 posts 186 karma points
    Nov 11, 2014 @ 09:22
    Richard Galt
    0

    I'm getting the same error after setting IIS to redirect traffic to HTTPS using URL rewriting. On 7.1.6 as well.

    error:

    Umbraco.Web.Scheduling.ScheduledPublishing
    An error occurred with the scheduled publishing
    System.Net.WebException: The operation has timed out
       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)
       at System.Net.WebClient.UploadString(Uri address, String method, String data)
       at Umbraco.Web.Scheduling.ScheduledPublishing.Start(ApplicationContext appContext)
    

    Rich

  • Sebastiaan Janssen 4664 posts 13046 karma points MVP admin hq
    Nov 12, 2014 @ 14:26
    Sebastiaan Janssen
    0

    Just as an update, we're fixing this in an upcoming 7.1.9 release (should be out soon-ish) - http://issues.umbraco.org/issue/U4-5728

  • Simon steed 350 posts 615 karma points
    Nov 14, 2014 @ 15:47
    Simon steed
    0

    Thanks Sebastiaan - what about a v6 patch, is that coming at all?

  • Arjan H. 128 posts 240 karma points
    Nov 20, 2014 @ 10:21
    Arjan H.
    0

    Hi Sebastiaan, will you also be releasing a patch for version 6.2.x?

    http://our.umbraco.org/forum/ourumb-dev-forum/bugs/59199-Errors-from-UmbracoWebSchedulingScheduledPublishing-and-UmbracoWebSchedulingKeepAlive http://issues.umbraco.org/issue/U4-5842

  • Sebastiaan Janssen 4664 posts 13046 karma points MVP admin hq
    Nov 23, 2014 @ 14:26
    Sebastiaan Janssen
    2

    I've added a patch for 6.2.4 in this issue: http://issues.umbraco.org/issue/U4-5728

  • Arjan H. 128 posts 240 karma points
    Nov 24, 2014 @ 10:25
    Arjan H.
    0

    Thanks, Sebastiaan!

  • Simon steed 350 posts 615 karma points
    Nov 24, 2014 @ 11:48
    Simon steed
    0

    Thanks Seb - where were you on Friday at the festival, we all missed you :-)

  • Matt Taylor 788 posts 1805 karma points
    Jan 15, 2015 @ 17:42
    Matt Taylor
    0

    My Umbraco 6.2.2 site's log is filled with similar errors.

    From what I have read here people are claiming URL Rewriting and File Change Notification settings are to blame.

    I'm using a rewrite rule force https so this could be my problem.

    Am I right in thinking this has been fixed in a later version of 6.2?

    If I cannot upgrage easily will <httpRuntime fcnMode="Disabled"/> fix it or will I need to find another way to force the use of SSL?

    Regards, Matt

  • Arjan H. 128 posts 240 karma points
    Jan 15, 2015 @ 17:50
    Arjan H.
    0

    @Matt: (Most of) these error should be fixed in version 6.2.5. Also, in my case a lot of these errors disappeared when I removed all the rewrite rules from /config/UrlRewriting.config and replaced them with rewrite rules /rewriteRules.config (using IIS URL Rewrite 2.0). To force HTTPS it would look like this:

    <?xml version="1.0" encoding="utf-8"?>
    <rules>
        <clear />
        <rule name="ForceHttps" stopProcessing="true">
            <match url="(.*)" />
            <conditions>
                <add input="{HTTPS}" pattern="off" ignoreCase="true" />
            </conditions>
            <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" appendQueryString="true" />
        </rule>
    </rules>
    
  • Matt Taylor 788 posts 1805 karma points
    Jan 15, 2015 @ 17:58
    Matt Taylor
    0

    Thanks Arjan,

    I'm currently doing my rewrite with the following in my web.config:

    <rewrite>
        <rules>
          <rule name="Redirect to HTTPS" stopProcessing="true">
            <match url="(.*)" />
            <conditions><add input="{HTTPS}" pattern="^OFF$" />
              </conditions>
            <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="Permanent" />
          </rule>
          </rules>
        </rewrite>

    Is that what you mean?

    Regards, Matt

  • Jeremy 21 posts 45 karma points
    Jan 15, 2015 @ 18:59
    Jeremy
    0

    Same problems here, 6.2.4

    fcnMode="Disabled"

    didn't help. I also installed Sebastiaan's patch for 6.2.4 which didn't resolve the issue.  I also force the entire site to HTTPS.  Really sucks because anytime I publish content the app restarts and locks up for 30 secs.  Any idea when 6.2.5 will be released?

  • Matt Taylor 788 posts 1805 karma points
    Jan 15, 2015 @ 19:21
    Matt Taylor
    0

    Ah, so that's why my stite is taking 30 to 40 seconds to start up! :-S

  • Arjan H. 128 posts 240 karma points
    Jan 15, 2015 @ 19:47
    Arjan H.
    0

    @Matt: Yes, of course you can also include those rewrite rules in the web.config. I prefer storing these rewrite rules and mappings in separate config files (rewriteRules.config and rewriteMaps.config) which I then include in the web.config:

    <system.webServer>
      <rewrite>
        <rewriteMaps configSource="rewriteMaps.config" />
        <rules configSource="rewriteRules.config" />
      </rewrite>
    </system.webServer>
    

    In my case these changes in combination with the 6.2.4 patch Sebastiaan provided fixed all the errors. Of course the 6.2.4 patch won't do you any good, since you're still on version 6.2.2. By the way, I also tried the fcnMode="Disabled" fix, but that didn't work for me either.

    @Jeremy/Matt: I've never had issues with application pools restarting after publishing content on a forced HTTPS site. So I'm guessing these two issues are unrelated. I assume you configured this in your web.config?

    <add key="umbracoUseSSL" value="true" />
    
  • Jeremy 21 posts 45 karma points
    Jan 15, 2015 @ 21:46
    Jeremy
    0

    I disabled the umbracoUseSSL value as I was running into random infinte loop redirects every couple weeks.  Didn't fix the issue.  Changed the rewrite rule to use {Request_URI} instead of {R:1}, no loops in a couple weeks so fingers crossed. umbracoUseSSL still set to false.

    Publishing throws a ton of errors in the trace log.   Been using Umbraco since 2009, first time I've seen this issue.

    Don't think the issue will be resolved until 6.2.5 released with the baseURL attribute, http://issues.umbraco.org/issue/U4-5965

     

     

     

     

  • Matt Taylor 788 posts 1805 karma points
    Jan 15, 2015 @ 22:31
    Matt Taylor
    0

    For now I've just taken out the https rewrite rule in the web.config to see what effect it has.

    I wouldn't be happy setting umbracoUseSS = false as you want to protect those log in credentials which will be in plain text otherwise.

    If the logs clear up I'll try re-instating the rewrite rule and changing using {Request_URI} instead of {R:1} like you have.

    Cheers, Matt

     

  • Matt Taylor 788 posts 1805 karma points
    Jan 28, 2015 @ 12:19
    Matt Taylor
    0

    The result of removing my rewrite rule from the web.config was was that the errors disappeared from the log.

    I then re-enabled the re-write rule but changed:

    <action type="Redirect" url="https://{HTTP_HOST}/{R:1}" redirectType="Permanent" />

    to

    <action type="Redirect" url="https://{HTTP_HOST}{REQUEST_URI}" redirectType="Permanent" appendQueryString="true" />

     

    Immediately the errors re-appeared. One every minute exactly to the second.

  • Arjan H. 128 posts 240 karma points
    Jan 30, 2015 @ 16:08
    Arjan H.
    1

    I just found out something very interesting. I'm using Application Initialization Module for IIS 7.5 to automatically start up application pools and web sites after a server reboot or an application pool recycle to improve web site responsiveness. IIS basically fakes request and pushes it directly into the IIS pipeline without hitting the network, and this causes Umbraco to save localhost:80/umbraco as the OriginalRequestUrl. And of course the ping and scheduled publishing won't working anymore, because they will both be making requests to localhost instead of the actual web site URL. Since I set all my application pools to do a recycle in the middle of the night, I kept getting these ping and scheduled publishing 404 errors in the Umbraco logs.

    As of IIS 8 you should be able to configure the initializationPage for each web site, but this feature isn't available in IIS 7.5:

    http://www.iis.net/configreference/system.webserver/applicationinitialization

    I'm going to disable the pre-load feature for my Umbraco web sites, and implement a separate web application which does use the pre-load feature and fires a request to all the Umbraco web sites, making sure the proper OriginalRequestUrl is set for each web site.

  • Biagio Paruolo 1435 posts 1552 karma points
    Feb 08, 2016 @ 09:52
    Biagio Paruolo
    0

    The new features give some problems with scheduling like I report here https://our.umbraco.org/forum/umbraco-7/using-umbraco-7/65355-Scheduled-Publishing-Error-404#239660

  • Sandor 13 posts 36 karma points
    Feb 20, 2015 @ 15:28
    Sandor
    0

    We have been running into some mysterious application restarts and multiple appdomains recently and eventually stumbled upon the following blogpost for DNN: http://www.dnnsoftware.com/community-blog/cid/154980/aspnet-file-change-notifications-and-dnn

    In this blog they mention issues very similar to ours and claim that it is caused by the large amount of directories used in their application. fcnMode="Disabled" eventually solved their solution and also solved ours.

    Although I have not tried to reproduce it yet I get the feeling that our problem was also caused by large amounts of directories, which has rissen dramatically since we have been using ImageProcessor an d Slimmage in our recent projects.

    Currently we are just sticking with the new fcnMode setting and haven't noticed any side affects yet.

  • denisedelbando 139 posts 336 karma points
    Mar 05, 2015 @ 18:42
    denisedelbando
    0

    i have a similar situation with Jeremy. 

    using 6.2.4 but the site is still logging those errors. 

  • Jeremy 21 posts 45 karma points
    Mar 05, 2015 @ 19:16
    Jeremy
    2

    Updating to 6.2.5 cleared those errors.  Just make sure you add a hostname in backoffice, set umbracoUseSSL = true in web.config if forcing your site to use SSL, and to add a baseUrl attribute to umbracoSettings.config:  i.e. <scheduledTasks baseUrl="www.domain.com/umbraco/">

    https://our.umbraco.org/contribute/releases/625/

  • denisedelbando 139 posts 336 karma points
    Mar 05, 2015 @ 20:43
    denisedelbando
    0

    @Jeremy before fixing the error, was umbraco hogging up  resources? our site kept going down so we had to keep restarting the app pool.

     

     

     

  • Jeremy 21 posts 45 karma points
    Mar 05, 2015 @ 22:58
    Jeremy
    0

    Memory usage was low, which is normal for our site.  During a save/publish on 6.2.4 the CPU would spike to 100% for 10-20 secs, but was normal when not making backoffice updates.

  • denisedelbando 139 posts 336 karma points
    Mar 09, 2015 @ 14:49
    denisedelbando
    0

    I was trying to replicate the error on a dev environment with ssl with umbraco 6.2.4. the error is not showing in the error log. this is so weird.

  • Jeremy 21 posts 45 karma points
    Mar 09, 2015 @ 16:20
    Jeremy
    0

    @avatart0ph did you configure host headers for the website in IIS?

  • denisedelbando 139 posts 336 karma points
    Mar 10, 2015 @ 15:06
    denisedelbando
    0

    we have not configured the host headers of the website in the production environment but in dev we have configured it like this 

    https://technet.microsoft.com/en-us/library/cc753195%28v=ws.10%29.aspx

     

  • denisedelbando 139 posts 336 karma points
    Mar 10, 2015 @ 15:44
    denisedelbando
    0

    i do not touch the prod IIS. the client's IT does it. But i have told them to fill in the variable and see how it goes. thank you Jeremy

  • denisedelbando 139 posts 336 karma points
    Mar 10, 2015 @ 19:45
    denisedelbando
    0

    the client does not want named bindings. i guess i am stuck with those errors.

  • Jeremy 21 posts 45 karma points
    Mar 10, 2015 @ 20:16
    Jeremy
    0

    Why not just upgrade to the 6.2.5 version?  That cleared up all the ScheduledPublishing errors for us.  Just make sure to set the new baseUrl attribute in the config file, configure a hostname in the backoffice, as well as set umbracoUseSSL to the correct value (true if you want all backoffice resrouces served via SSL).

  • Gus Braz 14 posts 38 karma points
    Mar 20, 2015 @ 01:11
    Gus Braz
    0

    I'm using umbraco 7.2.1, IIS 7.5, no load balancing, no url rewrites, no SSL, no scheduled tasks,

    yet, I still get the exceptions every minute.

    has anyone in a similar configuration found a solution?

    Thanks,

    Gus

     

     

     

     

  • Matt Taylor 788 posts 1805 karma points
    May 01, 2015 @ 11:33
    Matt Taylor
    0

    Upgrading to 6.2.5 seems to have cleared the errors for me too.

  • Gus Braz 14 posts 38 karma points
    May 08, 2015 @ 07:00
    Gus Braz
    0

    Hi there,

    I got umbracoUseSSL = "true" in my web.config

    and 

    scheduledTasks baseUrl="https://www.mydomain.com/umbraco" in umbracoSettings.config

    and the following errors still appear:

    2015-05-08 14:50:39,257 [79] ERROR Umbraco.Web.Scheduling.ScheduledPublishing - [Thread 25] An error occurred with the scheduled publishing

    System.Net.WebException: The remote name could not be resolved: 'https'

       at System.Net.WebClient.UploadDataInternal(Uri address, String method, Byte[] data, WebRequest& request)

       at System.Net.WebClient.UploadString(Uri address, String method, String data)

       at Umbraco.Web.Scheduling.ScheduledPublishing.Run()

    2015-05-08 14:50:39,257 [79] ERROR Umbraco.Web.Scheduling.KeepAlive - [Thread 15] Error in ping

    System.Net.WebException: The remote name could not be resolved: 'https'

       at System.Net.WebClient.DownloadDataInternal(Uri address, WebRequest& request)

       at System.Net.WebClient.DownloadString(Uri address)

       at Umbraco.Web.Scheduling.KeepAlive.Start(ApplicationContext appContext, IUmbracoSettingsSection settings)

     

    I am using Umbraco 7.2.1. I don't have any scheduled task that I need to run. Just trying to follow the steps above. 

    I am also not using load balancing.

    Does anybody have a suggestion?

    Many Thanks,

    Gus

  • schlubadub 102 posts 617 karma points
    Jul 01, 2015 @ 14:28
    schlubadub
    0

    Gus, You've probably solved this by now but it should be:

    <scheduledTasks baseUrl="www.mydomain.com/umbraco/">
    

    NOT like this:

    <scheduledTasks baseUrl="https://www.mydomain.com/umbraco">
    
  • Gus Braz 14 posts 38 karma points
    Jul 01, 2015 @ 22:47
    Gus Braz
    0

    Hi there,

    Thanks for your feedback.

    I did an Umbraco update to 7.2.5 and the ScheduledPublishing error disappeared.

    The KeepAlive error persists though. I have tried many different configurations for the baseUrl tag mentioned above (including using IP address). No success.

    Do you guys know how to eliminate this KeepAlive error?

    Thanks,

    Gus

  • Hoang Nghia 10 posts 90 karma points
    Aug 06, 2015 @ 03:46
    Hoang Nghia
    0

    Try this solution ;)

    our.umbraco.org/forum/umbraco-7/using-umbraco-7/57083-Error-with-SheduledPublishing-underlying-connection-was-closed#226307

  • JLon 289 posts 399 karma points
    Oct 25, 2015 @ 20:31
    JLon
    0

    HI all,

    Having the same issue on Umbraco V7.2.4 (no load balance, no schedule task too)

    But both schedule task error and keepAlive keeps showing in the log every minute

    Any solution to this yet?

    Thanks

  • Laurence Gillian 593 posts 1207 karma points
    Nov 05, 2015 @ 19:19
    Laurence Gillian
    1

    Umbraco 6.2.5

    Seeing these errors, when using HTTPS redirection handled in IIS.

    Have added:

    • baseUrl into umbracoSettings.config
    • enabled umbracoUseSSL in web.config

    Application startup, MUCH faster, and so far no errors. Fingers crossed!

  • Biagio Paruolo 1435 posts 1552 karma points
    Feb 08, 2016 @ 09:56
    Biagio Paruolo
    0

    Could you give more info? I've a site on 6.2.4. Is the same for 7.x?

  • Alejandro 23 posts 45 karma points
    Jun 03, 2016 @ 21:30
    Alejandro
    0

    Hi everyone,

    Is there a specific solution for this? I just upgraded an Umbraco 7.2.1 to a 7.4.3 and I'm getting these errors.

    This is a staging server, production with 7.2.1 also has this issues. Thanks!

  • Alejandro 23 posts 45 karma points
    Jun 07, 2016 @ 17:29
    Alejandro
    0

    I first tried setting baseUrl in scheduledTasks but the errors continued.

    I searched some closed issues in the tracker and found umbracoApplicationUrl in the web.routing tag. That fixed it!

  • Alejandro 23 posts 45 karma points
    Jun 19, 2016 @ 14:00
    Alejandro
    0

    So, what I commented before worked for staging, but for some reason it's not working in production. I'm getting

    ERROR Umbraco.Web.Scheduling.ScheduledPublishing - Failed (at "http://mydomain.com/umbraco"). System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond

    This is a multi site umbraco, but so is staging. So far functionality wise everything seems to be working. Any ideas or pointers as to what could be the issue?

    Thanks!

  • Norbert Haberl 30 posts 112 karma points
    Jun 20, 2017 @ 20:27
    Norbert Haberl
    0

    Any answer for this now???

  • Arlan Galvez 27 posts 156 karma points
    May 30, 2018 @ 21:07
    Arlan Galvez
    0

    I'm facing the same issue in Umbraco 7.6.3, any answer? Greetings.

  • lori ryan 51 posts 193 karma points
    1 week ago
    lori ryan
    0

    Anybody get a resolution?

  • lori ryan 51 posts 193 karma points
    1 week ago
    lori ryan
    0

    setting the umbracoApplicationUrl in the umbracosettings fixed this for me.

Please Sign in or register to post replies

Write your reply to:

Draft