Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • ECL 7 posts 37 karma points
    Mar 10, 2015 @ 15:55
    ECL
    0

    SMTP / Mailform problem

    Hi - I have installed the following starter kit

    https://uskinned.net/themes/synergy/

    However, when I attempt to use the mail form, I receive the following error:

    "There was an error sending your contact details. A from e-mail address must be specified in the From property or the system.net/mailSettings/smtp config section."

    My host is PipeTen - and they advised me to ask here. I have tried making the changes in web.config referred to in the following URLs

    http://www.pipeten.info/2008/11/when-and-where-to-use-webformpipetencouk/

    https://our.umbraco.org/forum/using/ui-questions/12294-Smtp-settings

    https://our.umbraco.org/wiki/how-tos/verify-that-your-smtp-settings-are-not-preventing-you-from-sending-e-mail

    I see a 500 error, but I am told that the error they see is as follows:

    "Configuration file is not well-formed XML " 71: "smtp deliverymethod=“Network” from=“[email protected]

    I appreciate that this may be due to me - but can anyone advise me as to what I can do to make this work?

    Thanks

  • Jan Skovgaard 11264 posts 23593 karma points MVP 9x admin c-trib
    Mar 10, 2015 @ 15:58
    Jan Skovgaard
    0

    Hi ECL

    in the /config/umbracoSettings.config file you need to specify a valid sender e-mail address I think.

    Also you need to setup some valid SMTP information in the web.config file as mentioned in the post you referenced above.

    I think this should work unless the theme does an override of these settings somehow.

    /Jan

  • Chriztian Steinmeier 2757 posts 8511 karma points MVP 6x admin c-trib
    Mar 10, 2015 @ 16:06
    Chriztian Steinmeier
    0

    Hi ECL,

    First: It looks like you've forgot the quotes on the attribute values - if you have XML that looks like this:

    smtp deliverymethod=Network [email protected]
    

    it should look like this to be valid XML:

    <smtp deliverymethod="Network" from="[email protected]"></smtp>
    

    (but the exact format depends on the file/ setting you're editing)

    For my sites and webhost, this is the line I usually need to put in Web.config:

    <network host="SMTP.SERVER.COM" port="25" userName="" password="" defaultCredentials="true" />
    

    And then my webhost requires a valid email address in the From: header, which is set in the umbracoSettings.config file, look for the notifications tag:

    <notfications>
        <email>[email protected]</email>
    </notifications>
    

    /Chriztian

  • Chuck Kirklen 36 posts 184 karma points
    Dec 05, 2015 @ 03:19
    Chuck Kirklen
    0

    YMMV, but this is what worked for me with the uSkinned Source starter kit on a Windows 2012 server, where 'myuser' and 'mypwd' are obviously the ones that are used at the hosting company for the account:

      <system.net>
    <mailSettings>
      <smtp from="[email protected]">
        <network host="127.0.0.1" userName="myuser" password="mypwd" />
      </smtp>
    </mailSettings>
    </system.net>
    
  • Marc Love (uSkinned.net) 402 posts 1456 karma points
    Dec 07, 2015 @ 15:08
    Marc Love (uSkinned.net)
    0

    Hi ECL,

    All you need to get your theme sending Mail is to get your mailSettings correct in web.config for the account you are using.

    We use sendgrid, which is a free service for up to 12,000 emails a month which should be more than enough.

    https://sendgrid.com/

    Cheers,

    Marc

Please Sign in or register to post replies

Write your reply to:

Draft