Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Sebastian Hoffback 5 posts 74 karma points c-trib
    Mar 18, 2015 @ 12:48
    Sebastian Hoffback
    0

    "You have unsaved changes" dialog after editing page with macro

    I reported this bug 4 weeks ago and have still heard nothing. I can't be the only one who thinks that this bug is really important and extremly frustrating for editors? We have tried digging thru the source and fixing it ourselves but no luck sofar.

    http://issues.umbraco.org/issue/U4-6265

    ---

    Steps to reproduce:

    1. Create a page with a "Richtext editor"

    2. Add a Macro (even a simple one with no settings, mine just has the word "test" in it)

    2. Save (it seems to work fine on the first save when you are creating the page)

    3. Save

    4. Navigate away

    The "You have unsaved changes" dialog will now appear even though you have just saved.

    The same procedure without the macro does not show the dialog.

    This is on Umbraco 7.2.2 running with an emedded database

  • Sebastian Hoffback 5 posts 74 karma points c-trib
    Mar 20, 2015 @ 09:16
    Sebastian Hoffback
    0

    Tried this again with the new release (7.2.3) and the bug is still there.

  • Jonas Söderström 8 posts 78 karma points
    Sep 23, 2019 @ 08:44
    Jonas Söderström
    0

    I have the same behaviour in 7.15.3. Thought this was fixed but apparently not, or is it something I´ve missed?

  • George 27 posts 109 karma points
    Oct 23, 2019 @ 17:06
    George
    0

    I'm also seeing this in 7.15.1.

  • Jonas Söderström 8 posts 78 karma points
    Oct 24, 2019 @ 05:46
    Jonas Söderström
    1

    The fix is cherry picked for release 7.15.4. (https://github.com/umbraco/Umbraco-CMS/issues/6366)

  • George 27 posts 109 karma points
    Oct 24, 2019 @ 13:11
    George
    1

    Thanks, Jonas! I applied the fix directly in 7.15.2 and that did the trick. For those who want to temporarily patch Umbraco until 7.15.4 is out, I applied the suggested update in Umbraco/Js/umbraco.controllers.js. Just search for the line starting:

    editor.on('SetContent'
    

    Then apply the update to the code suggested in the ticket Jonas links above.

    You'll need to change the version number in the config/ClientDependency.config file in order to force it to refresh some cached files. You may also want to clear your cache.

Please Sign in or register to post replies

Write your reply to:

Draft