Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Richard Barg 358 posts 532 karma points
    Jul 25, 2011 @ 19:34
    Richard Barg
    0

    Visual Studio 2008 and Umbraco 4.8

    1. Will Visual Studio 2008 compile correctly with Umbraco 4.8? I am asking this on behalf of our developer. We are upgrading from 4.3 to 4.8. 
    2. In addition, are there any advantages to useing Visual Studio 2010?
  • Sebastiaan Janssen 4847 posts 14373 karma points MVP admin hq
    Jul 25, 2011 @ 19:58
    Sebastiaan Janssen
    1

    First of all, there's no Umbraco 4.8, you probably mean 4.7.

    You don't need Visual Studio to upgrade Umbraco, but make sure to read the general upgrade instructionsupgrade instruction for 4.5 and the instruction for changing to the new XML schema very well, you might want to upgrade to 4.5.2 first and THEN to 4.7, it seems to get the best results. 

    Finally, you are probably going to need VS2010 (SP1) mostly for Razor support and possibly for .NET 4.0 support (I'm not sure 2008 supports .NET 4.0 and you NEED 4.0 to run Umbraco 4.7).

  • Aaron Powell 1708 posts 3043 karma points c-trib
    Jul 26, 2011 @ 00:52
    Aaron Powell
    0

    @Seb - yes .NET 4.0 came with VS2010 release so you can't compile from VS2008

     

Please Sign in or register to post replies

Write your reply to:

Draft