Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Simon Dingley 1393 posts 3246 karma points c-trib
    Feb 05, 2012 @ 12:09
    Simon Dingley
    0

    UmbracoExamine.UmbracoContentIndexer.ReIndexNode Exception on Publish

    After adding a new custom Examine IndexSet I get this when publishing nodes of the type that the index set is indexing. I've read of similar issues on the forum but got the impression this was resolved - any pointers appreciate?

    [ArgumentNullException: Value cannot be null.
    Parameter name: attribute]
       System.Xml.Linq.XAttribute.op_Explicit(XAttribute attribute) +91251
       UmbracoExamine.UmbracoContentIndexer.ReIndexNode(XElement node, String type) +107
       Examine.ExamineManager._ReIndexNode(XElement node, String type, IEnumerable`1 providers) +81
       UmbracoExamine.UmbracoEventManager.content_AfterUpdateDocumentCache(Document sender, DocumentCacheEventArgs e) +172
       umbraco.DocumentCacheEventHandler.Invoke(Document sender, DocumentCacheEventArgs e) +0
       umbraco.content.FireAfterUpdateDocumentCache(Document sender, DocumentCacheEventArgs e) +26
       umbraco.content.UpdateDocumentCache(Document d) +749
       umbraco.content.UpdateDocumentCache(Int32 pageId) +52
       umbraco.library.UpdateDocumentCache(Int32 DocumentId) +106
       umbraco.cms.presentation.editContent.Publish(Object sender, EventArgs e) +383
       System.EventHandler.Invoke(Object sender, EventArgs e) +0
       umbraco.controls.ContentControl.savePublish(Object Sender, ImageClickEventArgs e) +46
       System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e) +115
       System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +120
       System.Web.UI.WebControls.ImageButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5563

     

  • Euan Rae 100 posts 128 karma points
    Feb 05, 2012 @ 13:10
    Euan Rae
    0

    Are you using multiple document types in the <IncludeDocTypes> setting?

    I've had a similar issue and it was because the custom index was indexing fields that didn't exist in all the doc types that index set was for.  If that's the case the way to get around it is to manually add the field (if it's there) in the GatheringNodeData event.

    /Euan

     

  • Simon Dingley 1393 posts 3246 karma points c-trib
    Feb 05, 2012 @ 13:16
    Simon Dingley
    0

    No I am only using a single doctype, index configured as follows:

         <IndexSet SetName="EventIndexSet" IndexPath="~/App_Data/TEMP/ExamineIndexes/Events/">
            <IndexAttributeFields>
                <add Name="id" />
                <add Name="nodeName" />
                <add Name="updateDate" />
                <add Name="writerName" />
                <add Name="path" />
                <add Name="nodeTypeAlias" />
            </IndexAttributeFields>
            <IndexUserFields>
                <add Name="eventName" />
                <add Name="shortDescription" />
                <add Name="startDate" />
                <add Name="endDate" />
                <add Name="eventImage" />
                <add Name="postcode" />
            </IndexUserFields>
            <IncludeNodeTypes>
                <add Name="Event" />
            </IncludeNodeTypes>
            <ExcludeNodeTypes />
        </IndexSet>
  • Euan Rae 100 posts 128 karma points
    Feb 05, 2012 @ 13:36
    Euan Rae
    0

    OK, not that then...

    Have you tried removing the eventImage field to see if it is that issue with XML serilization?

  • Sanjay Zalke 10 posts 30 karma points
    Sep 25, 2012 @ 12:37
    Sanjay Zalke
    0

    Hi Simon/Euon,

    Did you resolve this issue. I am also facing same issue, I have index with no user fields or exclude nodes, but still it fails to save and publish the pages.

    If I remove the index completely the publish works fine.

    Here is the index defination.

    <IndexSet SetName="myIndexSet" IndexPath="~/App_Data/TEMP/ExamineIndexes/myIndexFolder/" >
        <IndexAttributeFields>
          <add Name="id" />
          <add Name="nodeName" />
          <add Name="path" />
          <add Name="nodeTypeAlias" />
          <add Name="parentID" />
        </IndexAttributeFields>
        <IndexUserFields />
        <IncludeNodeTypes />
        <ExcludeNodeTypes />
      </IndexSet>

    Sanjay

  • Simon Dingley 1393 posts 3246 karma points c-trib
    Sep 25, 2012 @ 13:17
    Simon Dingley
    0

    I don't recall exactly but it is case sensitive so can you check that things like parentID should not actually be parentId ?

  • Robert Hughes 87 posts 110 karma points
    Nov 20, 2012 @ 04:02
    Robert Hughes
    0

    Anyone get to the bottom of this one? Now I got me this issue.

  • Robert Hughes 87 posts 110 karma points
    Nov 20, 2012 @ 04:19
    Robert Hughes
    0

    Did some debugging (got source for Examine) and I was getting a 'no node published for id XXX' when it was trying to re-index the node. Some very unsafe code there - was actually failing writing a log funnily enough. Not sure why my node is not published however.

  • Simon Dingley 1393 posts 3246 karma points c-trib
    Nov 20, 2012 @ 08:27
    Simon Dingley
    0

    I'm pretty sure in my case I tracked it down through a process of elimination by adding the "IndexUserFields" proeprties in one by one until the problem occurred. I think it was down to a misspelled or missing doctype property.

  • Fabio Milheiro 74 posts 136 karma points
    Feb 22, 2013 @ 12:19
    Fabio Milheiro
    0

    http://issues.umbraco.org/issue/U4-1491#comment=67-4953

    Shannon Deminick's comment worked for me. Deleted items in recycle bin.

  • Craig Mayers 1 post 21 karma points
    Aug 12, 2013 @ 14:28
    Craig Mayers
    0

    Shannon Deminick's comment also worked for me, I completely emptied the Recycle Bin then 'Republished Entire Site' and then the Save and Publish option was working again for me.

    :D

  • Murray Roke 452 posts 839 karma points c-trib
    Nov 06, 2013 @ 04:34
    Murray Roke
    0

    Just 'Republishing Entire Site' worked for me

  • Bjørn Fridal 274 posts 784 karma points
    Mar 06, 2014 @ 10:50
    Bjørn Fridal
    0

    Hi,

    I had the same problem after making a copy of an EC2 Umbraco website.

    I deleted all the ExamineIndexes in APP_Data\TEMP and now I can publish again :)

    Cheers
    Bjørn 

Please Sign in or register to post replies

Write your reply to:

Draft