Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Bill 43 posts 64 karma points
    Jun 13, 2013 @ 13:18
    Bill
    0

    Runtime error when creating new nodes

    Umbraco v 4.11.8 (Assembly version: 1.0.4869.17899), SQL Server 2008 R2, Win 7

    Hi,

    When I attempt to create a new node I get the following:

     

    Server Error in '/' Application.
    The SqlParameter is already contained by another SqlParameterCollection.
    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. 
    Exception Details: System.ArgumentException: The SqlParameter is already contained by another SqlParameterCollection.
    Source Error: 
    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace: 
    [ArgumentException: The SqlParameter is already contained by another SqlParameterCollection.]
       System.Data.SqlClient.SqlParameterCollection.Validate(Int32 index, Object value) +5286953
       System.Data.SqlClient.SqlParameterCollection.AddRange(Array values) +250
       StackExchangeContrib.Profiling.SqlHelpers.SqlServer.ProfiledSqlServerHelper.ExecuteNonQuery(String commandText, SqlParameter[] parameters) +329
       umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters) +143
    
    [SqlHelperException: Umbraco Exception (DataLayer): SQL helper exception in ExecuteNonQuery]
       umbraco.DataLayer.SqlHelper`1.ExecuteNonQuery(String commandText, IParameter[] parameters) +318
       umbraco.BusinessLogic.Permission.MakeNew(User User, CMSNode Node, Char PermissionKey) +471
       umbraco.cms.businesslogic.CMSNode.MakeNew(Int32 parentId, Guid objectType, Int32 userId, Int32 level, String text, Guid uniqueID) +1773
       umbraco.cms.businesslogic.web.Document.MakeNew(String Name, DocumentType dct, User u, Int32 ParentId) +515
       umbraco.contentTasks.Save() +152
       umbraco.presentation.create.dialogHandler_temp.Create(String NodeType, Int32 TypeId, Int32 NodeId, String Text) +586
       umbraco.cms.presentation.create.controls.content.doCreation() +199
       umbraco.cms.presentation.create.controls.content.sbmt_Click(Object sender, EventArgs e) +34
       System.Web.UI.WebControls.Button.OnClick(EventArgs e) +9552602
       System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +103
       System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
       System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
       System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +35
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1724
    


    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.18044

    I've tried the usual tricks so worried that there is something seriously wrong with my database. Any pointers as to what else I could try would be massively appreciated.

    Thanks

    Bill


     

  • fermin saez 1 post 21 karma points
    Aug 17, 2013 @ 19:50
    fermin saez
    0

    I'm having the same problem in an umbraco 4.7.1 installation. If anyone could help, I'd be very grateful.

    Thanks.

  • Oliver Boardman 19 posts 130 karma points
    Sep 17, 2019 @ 12:26
    Oliver Boardman
    0

    I'm also having the same issue and reloading the models builder doesn't seem to do anything v7.14.0

    Worked fine for the previous 5 new pages i set up today, but then decided to stop working and throw up the runtime error

Please Sign in or register to post replies

Write your reply to:

Draft