Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Dan Christoffersen 64 posts 119 karma points
    Sep 22, 2009 @ 19:57
    Dan Christoffersen

    Member authentification fails on pages without .aspx

    I have made a homepage that uses membership logins for certian pages. On all pages I have a login status that shows wether or not you are logged in.

    I had some problems getting this to work and posted a thread about it here . I figured out, that authentification will not work if I am using SEO friendly urls - or rather, if the viewed page do not end with .aspx. So I changed back to using normal urls, and everything works fine.


    The front page of the homepage is not using the .aspx - it's just  So I am back to my starting point.

    The "funny" thing is, that if i write the page name - ie. it works. If i trace the two "different" pages, i can se that AUTH_TYPE, AUTH_USER, LOGON_USER and REMOTE_USER is null on the version without the .aspx extension, but have correct values on the front.aspx page.

    This might be some web.config thing, but I have really run out of things to try.

    Information on the umbraco version, urls to test etc. can be found on the older post mentionen above.

    I would really appreciate a littl help here.


  • James Hildeman 92 posts 88 karma points
    Sep 22, 2009 @ 21:18
    James Hildeman

    You can use SEO friends URLS but ASP.Net is not configured to run against all pages by default and that might be what you're running into.  Try  this under win2003:

    1. IIS Manager > properties > home directory > configuration > Wildcard application maps
    2. Click "Insert"
    3. Executable = c:\windows\\framework\v2.0.50727\aspnet_isapi.dll (or similar, see your .ascx extension for an example that works for you)
    4. Uncheck "Verify that file exists"
    5. OK, OK, OK

    That should then force all your pages to fall under ASP.Net execution and should cause your membership code work properly on all pages. 


  • Paul Blair 466 posts 731 karma points
    Sep 22, 2009 @ 22:03
    Paul Blair

    What version of IIS are you using?

    I have used the membership logins and friendly URL's on IIS7 and integrated pipelines.

    Here is my post on how I set up the project:

    setting up a new umbraco project

    Points #4 & #5 will be most relevent to you if you are using IIS7.



  • Dan Christoffersen 64 posts 119 karma points
    Sep 23, 2009 @ 14:52
    Dan Christoffersen

    <modules runAllManagedModulesForAllRequests="True"> from Poul's link did the trick.

    If you ever get to Roskilde, I'll buy you a beer, Poul.


Please Sign in or register to post replies

Write your reply to: