Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Damien 36 posts 160 karma points
    Mar 03, 2014 @ 13:32
    Damien
    0

    contentService.Delete method in console app

    Hi,

    I have an issue with this method (contentService.Delete) when using within a console app, within a user control and the context of the site it's fine.

    The problem seems to be related to the FileSystemProvider and I receive a null reference exception.

    I have the required config files and references in app config as per Morten's example on GitHub: https://github.com/sitereactor/umbraco-console-example/tree/master/UmbConsole

    Stack trace:

    at Umbraco.Core.IO.FileSystemProviderManager.

    Could anyone suggest what the problem might be please?

    Many Thanks

  • Tom 713 posts 954 karma points
    Mar 19, 2014 @ 23:06
    Tom
    0

    Hi we're getting the same issue.. any suggestions?

  • Damien 36 posts 160 karma points
    Mar 24, 2014 @ 18:07
    Damien
    0

    Hi Tom,

    I ended up copying all of the config files and most of the Umbraco site into my console app, it's messy but it works, my exe sits in the root of the app, I have it working standalone just a shame I have all of Umbraco with it and not just dll and config files.

    Let me know if you get it sorted, will dig the project out and give more detail if needed.

    Thanks

    Damo

Please Sign in or register to post replies

Write your reply to:

Draft