Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Niclas Schumacher 67 posts 87 karma points
    Mar 06, 2014 @ 11:31
    Niclas Schumacher

    examine leading wildcard enabled.

    Hello fellow search people! 
    I'm reworking my search functionality on a site.

    In the past i made my own Index, because, that was the way i learned it, and i added some data to the examine via ApplicationStartupHandler. But now i would like to use the stardard ExternalSearcher instead, and  add my data to that. 

    But i got an issue, that i can't use leading wildcard on the ExternalSearcher even though i have enabled ,  enableLeadingWildcards="true", in ExamineSettings.config. But that dosn't seem to do to trick, i still get the error saying i can't use either '?' or '*' as leading char in a search. THOUGH, i can do it on my own index. 

    Anyone who can tell me how come this is, why can't i do it on the externalSearcher, when i can on my own Index ? 


    Best regards Niclas Schumacher

  • Ismail Mayat 4397 posts 9604 karma points MVP 2x admin c-trib
    Mar 06, 2014 @ 15:14
    Ismail Mayat


    I would download examine source and step through it then see if enableLeadingWilcards is being set properly then in the bowels is it being set on lucene search/index I seem to recall that i did'nt so you would then get the error.



  • Jonas Eriksson 930 posts 1825 karma points
    Mar 24, 2015 @ 11:56
    Jonas Eriksson

    I got stuck on this aswell. The correct setting is without s enableLeadingWildcard="true"

    Confirm that the setting is ok by looking in the Examine Management dashboard

    After that you can do for example

    var wildCardQuery = "nodeName:" + query + "^3" + "nodeName:*" + query + "* " + "bodyText:" + query + " " + "*" + query + "*^0.8"; 
    var searchQuery = searchCriteria.RawQuery(wildCardQuery);
Please Sign in or register to post replies

Write your reply to: