Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Christian W. Larsen 27 posts 49 karma points
    Nov 03, 2009 @ 10:04
    Christian W. Larsen

    Umbraco.config not created

    I have a very strange problem. I posted a thread about it last week: My solution then was to restore the database from a backup - hoping that the problem would not return. But it did. 

    I have a rather big Umbraco-database containing about 35.000 nodes, which have been batch imported. Everything worked like a charm until I suddenly  get the splash screen saying "Looks like there's still work to to" - and umbraco.config is missing.

    Nothing happens when I republish the enitre site from Umbraco.

    Everything works in the backend - all nodes are there, I can publish, edit etc.

    I suspect that something is wrong with data or xml in a single node - but with 35.000 nodes its a bit hard to find out wich one. I have deleted nodes which were edited/created just before the error occured.

    Just before the error occurred I deleted a node (or at least tried to) from the website (front end) and got a timeout error.

    Does anyone have a clue what's going on? Something is clearly preventing Umbraco from generating the umbraco.config file and I'm pretty sure that it's a data problem (permissions etc are ok).




  • skiltz 501 posts 701 karma points
    Nov 03, 2009 @ 10:09

    I don't know the problem...But maybe you can debug the site in Visual Studio???  FInd the method that produces the Umbraco.config and go from there?  I presume there is nothing in the Umbraco Log?

  • Rasmus Berntsen 215 posts 253 karma points c-trib
    Nov 03, 2009 @ 10:18
    Rasmus Berntsen

    Does it create the umbraco.config if you manually try to save and publish a single node...? Not from the right-click menu but from the node itself... I've had problems with republishing entire sites.

  • Christian W. Larsen 27 posts 49 karma points
    Nov 03, 2009 @ 10:33
    Christian W. Larsen

    @Berntsen: No, it saves/publishes - but no umbraco.config

    @skiltz: I don't see how I can debug the backend?

  • Peter Dijksterhuis 1442 posts 1722 karma points
    Nov 03, 2009 @ 10:48
    Peter Dijksterhuis

    Try looking in the umbracoLog table and see what is written there. It might give you some additional clues if there where errors.



  • Christian W. Larsen 27 posts 49 karma points
    Nov 03, 2009 @ 11:53
    Christian W. Larsen

    Pheew - thanks a lot! I wasn't aware of umbracoLog, but just what I was looking for. 

    Turned out that one document contained an illegal character (0x04) and that crashed the umbraco.config xml.


  • dominik 711 posts 733 karma points
    Nov 11, 2013 @ 12:39

    Hello, We are facing the same issue (umbraco.config file is not generated) but the umbracoLog table does not show any error.

    We are using version 4.7.2

    Any idea?

Please Sign in or register to post replies

Write your reply to: