Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • savantKing99 70 posts 120 karma points
    Sep 08, 2014 @ 20:12

    Exclude nodes in examineIndex

    Hi everyone,

    I try to exclude the nodes. But if I Publish every time the site, then the it is not anymore excluded, Because I only want to , in this case search in the page Projecten in the site. I do it like this:

    <?xml version="1.0"?>
    Umbraco examine is an extensible indexer and search engine.
    This configuration file can be extended to create your own index sets.
    Index/Search providers can be defined in the UmbracoSettings.config
    More information and documentation can be found on CodePlex:
      <!-- The internal index set used by Umbraco back-office - DO NOT REMOVE -->
      <IndexSet SetName="InternalIndexSet" IndexPath="~/App_Data/TEMP/ExamineIndexes/Internal/"/>
      <!-- The internal index set used by Umbraco back-office for indexing members - DO NOT REMOVE -->
      <IndexSet SetName="InternalMemberIndexSet" IndexPath="~/App_Data/TEMP/ExamineIndexes/InternalMember/">
          <add Name="id" />
          <add Name="nodeName"/>
          <add Name="updateDate" />
          <add Name="writerName" />
          <add Name="loginName" />
          <add Name="email" />
          <add Name="nodeTypeAlias" />
      <!-- Default Indexset for external searches, this indexes all fields on all types of nodes-->
      <IndexSet SetName="ExternalIndexSet" IndexPath="~/App_Data/TEMP/ExamineIndexes/External/" />
      <IndexSet SetName="XFSIndexSet" IndexPath="~/App_Data/XFS/Index">
         <add Name="bodyProject" />
          <!--<add Name="ProjectPage"/>-->
          <add Name="Cat" />
          <add Name="Slides" />
          <add Name="slide" />
          <add Name="TextPageTwoColumns" />
          <add Name="ActionTextPage" />
          <add Name="umbTextPage" />
          <add Name="Search" />
          <add Name="umbNewsOverview" />
          <add Name="umbNewsItem" />
          <add Name="News Item" />
          <add Name="News Overview" />
          <add Name="umbHomePage" />
      <IndexSet SetName="XFSMediaIndexSet" IndexPath="~/App_Data/XFS/Index" />

    Thank you

  • Janet Kirklen 102 posts 212 karma points
    Sep 08, 2014 @ 22:50
    Janet Kirklen

    It looks like you have values in both the <IncludeNodeTypes> and in the <ExcludeNodeTypes>.   This may be confusing the indexer.  I suspect you need to pick one or the section other and not put values in both. 

    If you have <add Name="Cat"/> in IncludeNodeTypes, then you are telling the indexer that that is the only nodeTypeAlias that you want the indexer to use.  All other nodeTypeAliases would be excluded so you don't need anything in the ExcludeNodeType section.  

    If you have nodes listed in ExcludeNodeTypes, then you are telling the indexer that all nodeTypes except the ones in your list should be indexed.  Since "Cat" is not in the exclude list it would be inclued in the index. 

  • savantKing99 70 posts 120 karma points
    Sep 09, 2014 @ 09:29

    Hi Janet,

    Thank you for your comment. I have it now like this:

          <add Name="ProjectPage"/>
         <add Name ="ProjectOverview"/>
          <!--<add Name="Cat" />-->

    But still It looks also in other pages, other then projectpage

  • Janet Kirklen 102 posts 212 karma points
    Sep 09, 2014 @ 16:35
    Janet Kirklen

    Are you sure that the correct IndexSet is being used by you query?  

    From your ExamineIndex.config:

    <IndexSet SetName="ExternalIndexSet" IndexPath="~/App_Data/TEMP/ExamineIndexes/External/">

    In your code:  

    var searcher = ExamineManager.Instance.SearchProviderCollection["ExternalIndexSet"];

    If you are specifying this in your code check your ExamineSettings.config and see if you have a defualt set:  

    <ExamineSearchProviders defaultProvider="ExternalSearcher">   

    Have you used the backoffice Documents --> Examine Management tab to view your indexers and searchers?   You could try rebuilding your index to be sure any changes to your config settings have been picked up if no new pages have been published.  



Please Sign in or register to post replies

Write your reply to: