Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Damian Green 452 posts 1433 karma points
    Oct 08, 2014 @ 19:54
    Damian Green

    Umbraco search not picking up items in index

    If i delete and rebuild my sites indexes with a restart they are created fine.

    If i inspect the index with Luke all the data is in there and for example on the External index i can search for home on nodeName and in comes my Home node in the search results.

    However if i run this search from Umbraco i get nothing returned.

    I have also tried with Home (and this works for internal and external indexes) but again get nothing from Umbraco.

    If i republish the home node then do a search for home in Umbraco i get the home node in the search result - but if i then search for another node again i get nothing - unless i republish that also!

    Any idea whats wrong anyone?

    Member nodes ARE getting returned from the search however.

    Its seriously odd - and doing my head in now. Lost half a day on this.

  • Damian Green 452 posts 1433 karma points
    Oct 09, 2014 @ 12:15
    Damian Green

    A temp workaround is to reupublish the entire site (ignoring unpublished nodes) but thats not great is it. :o(

    If we use the last published date to monitor aged documents (which we will be) that will go out of the window. Plus unpublished documents are still not going to go in the index.

    Is there anywhere I can turn on verbose logging for examine so i can get a bit moire info of what may be going wrong?

  • Damian Green 452 posts 1433 karma points
    Oct 09, 2014 @ 13:09
    Damian Green

    Ive set the loggin to verbose but not getting anything extra.

    I am beginning to think this is an Umbraco Cache issue as everything is in the index if i inspect with Luke.

    Does Umbraco cache the lucene indexes somehow? And how could i get it to update this?

Please Sign in or register to post replies

Write your reply to: