Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Chima 1 post 21 karma points
    Jun 30, 2011 @ 17:08
    Chima
    0

    Lucene error "[UmbracoExamine] Field XXX is listed multiple times in the index set YYY. Please ensure all names are unique"

    Hi,

    We have Lucene installed, but about a week ago the search function stopped bringing back a complete set of results.  For instance, where a particular search term ("Berlin") used to bring back about 3 pages of results, the same search term is now only delivering 1 result page with three items on it.

    The error log in the database has this entry that I think may be related:

    [UmbracoExamine] Field "DertIndexSet" is listed multiple times in the index set "title". Please ensure all names are unique

     

    This chap encountered a similar problem:

    http://our.umbraco.org/forum/ourumb-dev-forum/bugs/13364-Field-email-is-listed-multiple-times-in-the-index-set-InternalMemberIndexSet

     

    We have tried to force a rebuild of the search a few times by:

    - republishing all the home page node

    - calling the ExamineManager.Instance.RebuildIndex() method in code

    - deleting the files from 'Index' and 'Queue' folders and rebuilding these using both of the above steps.

     

    Would anyone be able to shed any light on this, or let me know where we are going wrong?

    Thanks!

  • Chris Houston 534 posts 979 karma points MVP admin c-trib
    Jun 28, 2016 @ 11:08
    Chris Houston
    0

    We are experiencing this error after doing an Umbraco upgrade from 7.2.6 to 7.4.3 and wondered if anyone knows the answer, it did not appear in the log before the upgrade.

Please Sign in or register to post replies

Write your reply to:

Draft