Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Angelo 17 posts 38 karma points
    Aug 28, 2012 @ 19:05
    Angelo
    0

    AjaxControlToolkit ModalPopupExtender

    I am running Umnraco 4.8.1 and have downloaded AjaxControlToolkit from coldeplex and tried to use the ModalPopupExtender and it is not working. 

    I created a webcontrol in a new web application and there ModalPopupExtender worked like charm.

    code in webcontrol: 

    <%@ Register Assembly="AjaxControlToolkit" Namespace="AjaxControlToolkit" TagPrefix="cc1" %>

    <scriptmanager...../>
    <asp:Panel ID="pnl_Login" runat="server" Visible="true">
    ...
       <asp:LinkButton ID="PasswordRecoveryLink" runat="server" OnClick="PasswordRecoveryLink_Click"
       </asp:LinkButton>
    </asp:Panel>
    <asp:Panel ID="RecoverPassword" runat="server" CssClass="password_panel">
       <div class="RecoverPass">
       ...
       </div>
       <div id="Div_Emailed"...>
       ...
       </div>
       <div class="PassRetButton">
       ...
           <asp:LinkButton ID="CancelRecover" runat="server" Text="Cancel"></asp:LinkButton>
       </div>
    </asp:Panel>
    <cc1:ModalPopupExtender BehaviorID="PasswordRecovery_ModalPopupPanel" ID="PasswordRecovery_ModalPopup"
        runat="server" TargetControlID="PasswordRecoveryLink" PopupControlID="RecoverPassword"
        BackgroundCssClass="ModalBackground" CancelControlID="CancelRecover">
    </cc1:ModalPopupExtender>
    This works like a charm.
    Now this webcontrol does not work in umbraco.
    I know that in umbraco this will change
    <cc1:ModalPopupExtender BehaviorID="PasswordRecovery_ModalPopupPanel" ID="PasswordRecovery_ModalPopup"
        runat="server" TargetControlID="ContentPlaceHolderDefault_ContentPlaceHolderDefault_RecoverPasswordPasswordRecoveryLink" PopupControlID="RecoverPassword"
        BackgroundCssClass="ModalBackground" CancelControlID="ContentPlaceHolderDefault_ContentPlaceHolderDefault_CancelRecover">
    </cc1:ModalPopupExtender>
    The page compiles well but it does not work in Umbraco.
    in HTML browser view source I see the ID as ContentPlaceHolderDefault_ContentPlaceHolderDefault_RecoverPasswordPasswordRecoveryLink
    but __dopostback( has $c100$c100$c100$ContentPlaceHolderDefault$ContentPlaceHolderDefault$RecoverPasswordPasswordRecoveryLink
    Seems like due to this it is not working.
    Any clues so it works.
    I have tried putting the code directly is master file. Still it does not work. Any tips?

Please Sign in or register to post replies

Write your reply to:

Draft