Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • CodeMaster2008 151 posts 184 karma points
    Dec 11, 2012 @ 20:55
    CodeMaster2008
    0

    Resource not found (404 error) - /umbraco/RenderMvc - After submit form

    I created the form following the tutorial available on this link (documentation):

    Creating HTMl forms

    But when I click the submit button I get this HTTP 404 error:

    The resource cannot be found.
    Requested URL: /umbraco/RenderMvc

    The code is pretty much the same as the demo and the form is a partial view which is inserted in the page using "Html.Partial(_ContactForm)"

  • CodeMaster2008 151 posts 184 karma points
    Dec 11, 2012 @ 20:57
    CodeMaster2008
    1

    I forgot to mention, I'm using 4.11.1 
    (sry but the forum won't allow me to edit the post it returns, some XSL error message :-)

  • CodeMaster2008 151 posts 184 karma points
    Dec 11, 2012 @ 21:14
    CodeMaster2008
    2

    Found the issue, was related to name convention.
    Controller was named "ContactFormSurfaceController" and I was calling "ContactForm", when I should be calling "ContactFormSurface"

  • Biagio Paruolo 1429 posts 1526 karma points
    Dec 23, 2014 @ 12:01
    Biagio Paruolo
    0

    Good tips.

  • Pratham 4 posts 24 karma points
    Mar 10, 2015 @ 06:12
    Pratham
    0

    Same error, Can you suggest how to solve this error.

  • Jan Skovgaard 11031 posts 22288 karma points MVP 4x admin c-trib
    Mar 10, 2015 @ 07:02
    Jan Skovgaard
    0

    Hi Pratham and welcome to our :)

    Same code? Otherwise please share - The same error is not necessarily the result of the exact same issue. Otherwise I would assume that the post marked as the solution would be the same thing that you need to change in your code?

    /Jan

  • Dhiren 58 posts 198 karma points
    Mar 23, 2015 @ 08:21
    Dhiren
    0

    Hi Jan,

    We are facing same error on our live environment. Strange part is, we are getting this error randomly. Most of time form gets submitted properly, but sometimes this error occurs. Can you please help.

    Current Umbraco Version : 7.1.4
    Web.config has following changes.

    umbracoPath :  ~/abcd
    umbracoReservedPaths : ~/abcd

    Changing this Umbraco path can be the issue??

    Please suggest.

    Thanks,
    Dhiren 

     

  • Thor Østergaard 37 posts 58 karma points
    Apr 10, 2015 @ 12:02
    Thor Ƙstergaard
    0

    I do have the same issue in Umbraco 7.2.4.

    Clean install using one of the 3 default templates!

    Kind of funny because the templates try to promote Umbraco Forms:)

  • Hendy Racher 829 posts 3732 karma points admin
    Jan 25, 2016 @ 16:12
    Hendy Racher
    0

    Hi,

    Does anyone have any ideas as to what might be causing this 'random' issue ? The majority of the time posts to surface controllers all work fine, but occasionally it YSODs with: "There is not current PublishedContentRequest, it must be initialized before the RenderRouteHandler executes", with the url: '/umbraco/RenderMvc' in the browser.

    I'm guessing that the hidden 'ufprt' value is unable to be processed for some reason ?

    (this is with Umbraco v7.3.4)

    Thanks, Hendy

  • Laurence Gillian 593 posts 1207 karma points
    Aug 15, 2017 @ 09:50
    Laurence Gillian
    0

    I'm seeing this when using the default 'out of the box' Umbraco Logout form.

    Did any one figure out a solution? (v7.6.3)

    I'm going to upgrade and see if it goes away!

  • Sam 68 posts 363 karma points
    1 week ago
    Sam
    0

    Has anyone else had any luck with this. I am trying to make a two step form following this tutorial: https://umbraco.com/blog/creating-multi-step-forms-using-a-surfacecontroller/

    Every time I hit next umbraco looks for /umbraco/RenderMvc as the path.

Please Sign in or register to post replies

Write your reply to:

Draft