Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Magnus Olsson 25 posts 71 karma points
    Jun 18, 2013 @ 10:02
    Magnus Olsson
    0

    Installing Glimpse MVC plugin makes site go 404

    Hi,

    I want to use Glimpse for inspecting my server side. I'm running a fresh 6.1.1 in Mvc mode and latest Glimpse from Nuget. 

    Using only Glimpse Core 1.4.2 and ASP.NET modules it works, but when I install the Glimpse MVC 4 plugin all pages on my site goes 404 Not found. Removing the MVC4 plugin restores pages and basic Glimpse. Although without the MVC specifics in the Tabs. (TImeline is very limited as it does not display controllers/actions/views etc)

    Anyone using Glimpse MVC and Umbraco 6.x? Any tips on this? Could it be somehow that the request pipeline gets messed with? 

    Thanks in advance,
    /Magnus

     

  • Justin Moore 41 posts 100 karma points
    Jul 24, 2013 @ 12:56
    Justin Moore
    1

    Same problem here using Umbraco 6.1.1 MVC. Glimpse is working in the back office for me but I get 404 not found for front end when Glimpse is enabled

     

  • Justin Moore 41 posts 100 karma points
    Jul 24, 2013 @ 12:59
  • Magnus Olsson 25 posts 71 karma points
    Jul 24, 2013 @ 13:10
    Magnus Olsson
    0

    I could not get uGlimpse to work unfortunately. My findings were that it is for an older version of Glimpse. (0.87 = todays plugins don't work = no MVC) I grabbed the source for it over at Bitbucket and tried to recompile against new Glimpse but the interfaces seems to be all different.

  • Nik Molnar 1 post 24 karma points
    Aug 16, 2013 @ 17:43
    Nik Molnar
    3

    I'm not an Umbraco developer, but I do know quite a bit about Glimpse and would happily help you upgrade uGlimpse to work with newer builds of Glimpse.

    Glimpse has a developer mailing list that would be great for you to post your questions to.

    Thanks,

    Nik - Glimpse Co-Founder

  • James Jackson-South 489 posts 1746 karma points c-trib
    Apr 07, 2016 @ 21:43
    James Jackson-South
    0

    Hi Nik,

    Did anyone ever get back to you on this? I am still unable to get Glimpse MVC running with Umbraco. I'd love to figure out what Umbraco does that prevents it working out of the box.

    Cheers

    James

  • Lee Kelleher 3994 posts 15622 karma points MVP 12x admin c-trib
    Sep 16, 2013 @ 18:59
    Lee Kelleher
    2

    I ran into the same issue when using the Glimpse.MVC4 NuGet package - 404 for any frontend request / backoffice was fine - (it also gave me bunch of warnings in Visual Studio about the dependencies being out of date).

    So I uninstalled the 'Glimpse.MVC4' package (and dependencies), then just installed the Glimpse.AspNet package... and all worked as expected.

    Cheers,
    - Lee

  • Chris Houston 533 posts 978 karma points MVP admin c-trib
    Aug 07, 2014 @ 12:11
    Chris Houston
    0

    I know this is an old thread, I just wondered if anyone managed to get Glimpse.Mvc4 working with Umbraco 7.x

    I have tried to install it and receive the same 404 errors for frontend pages, it's a shame is it looks like a nice tool and would be great to extend with an Umbraco debugging tab ;)

  • Jeroen Breuer 4872 posts 12192 karma points MVP 3x admin c-trib
    Aug 07, 2014 @ 13:26
    Jeroen Breuer
    0

    Hello,

    Do you know this package? http://our.umbraco.org/projects/developer-tools/glimpse7

    Jeroen

  • Ian 23 posts 113 karma points
    Jan 06, 2017 @ 10:57
    Ian
    0

    Confirmed that Glimpse.MVC5 also results in front end 404s :(

    I really need the Model Binding tab which the Glimpse7 package doesn't appear to give.

  • Mahgo 32 posts 152 karma points
    Feb 23, 2017 @ 08:42
    Mahgo
    0

    Has anyone managed to work out how to fix this? I too am having this problem. Are there any other decent profiling tools that work with Umbraco apart from Miniprofiler?

Please Sign in or register to post replies

Write your reply to:

Draft