Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Stephen 'KINK' Wilde 23 posts 94 karma points
    Apr 16, 2015 @ 15:05
    Stephen 'KINK' Wilde
    0

    404 Error Pages don't respect Culture

    Umbraco version 7.2.4

    My current code looks like (and before anyone says this - YES - I have added the PassThrough setting into web.config)

    <errors>
        <error404>
            <errorPage culture="default">1224</errorPage>
            <errorPage culture="en">1224</errorPage>
            <errorPage culture="fr">1256</errorPage>
        </error404>
    </errors>
    

    Doesn't work - will only return the English version

    <errors>
        <error404>
            <errorPage culture="fr">1256</errorPage>
        </error404>
    </errors>
    

    works - now returns French version as expected

    <errors>
        <error404>
            <errorPage culture="en">1224</errorPage>
            <errorPage culture="fr">1256</errorPage>
        </error404>
    </errors>
    

    add English back in and it now only uses the French version

    So does anyone have any solution to this? I do not want to create custom handlers as umbraco out of the box should already support this, and is even documented as saying so.

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Apr 16, 2015 @ 15:15
    Jan Skovgaard
    0

    Hi Stephen

    Is it the same behavior if you put the default last so it looks like

    <errors>
        <error404>
            <errorPage culture="en">1224</errorPage>
            <errorPage culture="fr">1256</errorPage>
            <errorPage culture="default">1224</errorPage>
        </error404>
    </errors>
    

    Remember to recycle the app pool afterwards.

    /Jan

  • Stephen 'KINK' Wilde 23 posts 94 karma points
    Apr 16, 2015 @ 21:46
    Stephen 'KINK' Wilde
    0

    I'm afraid not. The weird thing is all other dictionary items work.

    I made the change, then rebuilt solution (built, rebuilt and cleaned many times) and it still only shows the English version.

    I have also pushed to my live site, recycled and it still doesn't work.

  • Jan Skovgaard 11241 posts 23387 karma points MVP 6x admin c-trib
    Apr 17, 2015 @ 06:35
    Jan Skovgaard
    0

    Hi Stephen

    Ok...then I'm afraid it's probably a bug - I think you should file an issue if none already exists about this.

    I don't have any ideas about how to work around it unfortunately. Since it's working fine as long as the default entry is just not there the usual suspects can be ruled out I think.

    /Jan

  • Chriztian Steinmeier 2698 posts 8107 karma points MVP 3x admin c-trib
    Apr 17, 2015 @ 07:49
    Chriztian Steinmeier
    101

    Hi Stephen,

    Maybe have a look at this thread - we did find there to be a few kinks, but also a workaround that worked: Setting up error pages in a multilingual site.

    I can see we're using the full ISO code for the languages (i.e., "en-US" instead of just "en") which you're not (don't know how fallbacks should work in this case - depends on what Umbraco is asking for, I guess?). Also, there had to (probably still have to) be hostnames assigned to the nodes.

    Hope you get it working,

    /Chriztian

  • Stephen 'KINK' Wilde 23 posts 94 karma points
    Apr 17, 2015 @ 09:18
    Stephen 'KINK' Wilde
    0

    Indeed this is a bug within the system, but the workaround atm is to include a domain in the "Hostnames and Cultures" section.

Please Sign in or register to post replies

Write your reply to:

Draft