Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • xrisdoc 53 posts 101 karma points
    Oct 31, 2015 @ 00:01
    xrisdoc
    0

    Running Back Office on OSX

    Hello

    I am trying to run the Back Office on OSX as outlined at https://our.umbraco.org/Documentation/Development-Guidelines/building-angular-project

    However, when I run grunt dev, as far as I can tell, it all seems to be fine according to the output within the terminal and then opens a browser window to http://localhost:9990/belle/

    But the browser doesn't display anything, just a blank page with the following errors listed within the console:

    • Failed to load resource: the server responded with a status of 404 (Not Found) -http://localhost:9990/belle/lib/bootstrap-tabdrop/bootstrap-tabdrop.min.js

    • Error: No module: ngMockE2E - angular.min.js:358

    The first error is easily fixed (but i am still wondering why this min file is not in that location), leaving the second error still to be resolved. So, I am just wondering if anyone else has experienced a similar issue when attempting to do this and to see if I can get this up an running.

    I am using the dev-7 branch from the Umbraco-CMS git repo.

    Thanks,

    Chris

  • xme 22 posts 84 karma points
    Oct 31, 2015 @ 01:10
    xme
    0

    Hello, I have made this turnaround without success.

    If you fail too, try this: Install BOOTCAMP on your Mac (it's preinstalled anyways) and have access to Windows on your Mac, which is really great!

    All the best

  • Simon Justesen 43 posts 100 karma points
    Oct 31, 2015 @ 01:52
    Simon Justesen
    0

    You cannot run Umbraco via localhost on a Mac because the project still features some Microsoft-specific dependencies, I believe.

    I hope that once Microsoft releases .Net 5.0 sometime next year, we'll be able to host Umbraco anywhere.

    As xme writes, install Bootcamp or some other virtualisation software and run Windows from it. Remember to enable IIS, or If you're using Visual Studio, there's a lightweight version of IIS dubbed "IIS Express" bundled with it.

  • xrisdoc 53 posts 101 karma points
    Oct 31, 2015 @ 03:55
    xrisdoc
    0

    I understand that we can't run Umbraco on OS X (yet!), but I am not trying to run the full Umbraco on OSX.

    I am only trying to run the Backoffice (Umbraco.Web.Ui.Client), which is simply an AngularJS app that has no dependencies on ASP.NET or Windows.

    The information outlined at https://our.umbraco.org/Documentation/Development-Guidelines/building-angular-project indicates that this can be done OS X using Node.js and that it will mock the data model for the relevant services.

    Thanks, Chris

  • David 1 post 71 karma points
    Jan 10, 2017 @ 17:54
    David
    0

    Hello,

    In my case, I've just tried with different versions from the git source code, and the release 7.1.0 works fine form my side.

    What I have done is:

    git checkout release-7.1.0 (on the root folder)
    cd /src/Umbraco.Web.UI.Client/
    npm install
    grunt dev
    

    David.

Please Sign in or register to post replies

Write your reply to:

Draft