Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Nigel Wilson 944 posts 2076 karma points
    Feb 19, 2010 @ 03:12
    Nigel Wilson
    0

    Last Updated Date for Member Changes

    Can anyone confirm if a date/time stamp is recorded when a change is made to a member record ?

    I note there is an updateDate in the XML field of cmsContentXML however this does not appear to change when updating a Member record.

    Can anyone shed light on this one please ?

    Thanks


    Nigel

  • Lee Kelleher 3993 posts 15621 karma points MVP 12x admin c-trib
    Feb 19, 2010 @ 09:22
    Lee Kelleher
    102

    Hi Nigel,

    I've had a quick look over the database and unfortunately can't see any update/modified date for members.  The "updateDate" attribute in the XML is purely there because it is using the same schema ... but the value is the same as "createDate".  No versioning happens with members.

    Best solution at present is to create a new property field for a member, (called it whatever, e.g. "lastModified").  Then hook into the Member.AfterSave event, and set the date manually.  It might feel like a bit of a hack, but it's a workable solution!

    Good luck, Lee.

  • Nigel Wilson 944 posts 2076 karma points
    Feb 19, 2010 @ 19:21
    Nigel Wilson
    0

    Hi Lee

    Thanks for your reply.

    Yeah your suggestion is exactly what I thought I'd have to do - "all" member modifications are going to be from the front end so can easily add a custom property and code for that.

    Nigel

  • keilo 566 posts 1021 karma points
    Oct 28, 2016 @ 04:31
    keilo
    0

    I came across this post while looking for member updateDate.

    Lee Kelleher would you happen to know what might be going wrong in the following case:

    • inherited a cms running 7.3 upgraded to 7.4, 7.5 then 7.5.2, 7.5.3 and finally 7.5.4 assembly: 1.0.6136.27241

      on 7.5.2/3/4 (snapshots for each taken) I seem to have this mysterious issue about updateDate on the Member Type:

    When i to go Member-> MemberType -> 'Subscriber' and try to simply add a new member custom field like 'test' textstring dataType and proceed to Save, it throws error notice:

    "The alias updateDate is a reserved term and cannot be used"

    I see the updateDate alias is protected but somehow it made its way to the member type field, and shows as text field.

    I checked the Event Handlers and there is nothing getting in the way.

    Now I cant seem to edit;

    • like change its type to datetime which I assume should be the default?)
    • upon removing updateDate, I cant save any member, when trying to save it throws error below

    Is there a manual way to fix this mysterious updateDate of member type property from the DB as I cant do a clean install on this system?

    An error occured

    The given key was not present in the dictionary.

    EXCEPTION DETAILS

    System.Collections.Generic.KeyNotFoundException: The given key was not present in the dictionary.

  • keilo 566 posts 1021 karma points
    Oct 28, 2016 @ 05:08
    keilo
    0

    I can see from the db cmsPropertyType there are two updateDates, one corresponding to Subscriber(1113) and one for the default member(1180)

    Removing any of this manually gives the exception above when saving a member in backoffice.

    If kept as it is, and tried to add a new property to MemberType I get the updateDate reserved error and wont let me.


    id dataTypeId contentTypeId propertyTypeGroupId Alias Name uniqueID

    283 -88 1113 NULL updateDate updateDate 85F6F82B-B0EF-246A-2CA3-992A6B0A48F8

    284 -88 1180 NULL updateDate updateDate 95AFB879-0CC8-F096-6FAA-CE2B763250AA

  • keilo 566 posts 1021 karma points
    Oct 28, 2016 @ 05:55
    keilo
    0

    Not sure how its fixed but I did find a way, recording here for reference to others with such strange case;

    • I have tried deleting the Examine indexes and clientdependency but that didnt seem to solve the issue.
    • I have removed the updateDate from both MemberTypes in the back office, revert the version in web.config to 7.5.3 (from 7.5.4) and re-copied the /bin /umbraco and /umbracoClient folder from 7.5.4 install
    • After re-installing 7.5.4, the error is gone. updateDate cant be seen in cmsproperty and saving member works as expected.

    I am still not sure what was preventing this before the update. Perhaps one with more knowledge can comment on, as updateDate works different in Members at the least.

Please Sign in or register to post replies

Write your reply to:

Draft