Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • David Loosley 13 posts 33 karma points
    Mar 01, 2012 @ 15:39
    David Loosley
    0

    Error parsing XSLT file

    I've just uploaded my first Umbraco website (4.7.1.1) to a hosted web service. Unfortunately all the XSLT marcos on every page displays the message "Error parsing XSLT File"

    I have gone into the developers environment and whenever I save an existing or create a new XSLT macro I get the following error:

    Unable to load one or more of the types in assembly 'System.Data.SqlServerCe, Version=4.0.0.1, Culture=neutral, PublicKeyToken=89845dcd8080cc91'. Exceptions were thrown:
    System.Security.SecurityException: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089' failed.

     

    Can anyone help with this?

    TIA

    David

     

  • Jan Skovgaard 11264 posts 23592 karma points MVP 9x admin c-trib
    Mar 01, 2012 @ 16:01
    Jan Skovgaard
    0

    Hi David

    Have you by any chance created som custom xslt extensions or installed some packages that are using some custom xslt extensions? In that case make sure that the xsltExtensions.config file on your local environment (which I asume is working) is identical with the one on your server. The file is located in the "config" folder.

    If this does not solve it then it perhaps has something to do with some .dll files that are not needed...but I'm not sure, which ones it could be. Have just seen other people have this issue where that has been the case...

    /Jan

  • Thomas Höhler 1237 posts 1709 karma points MVP
    Mar 01, 2012 @ 16:50
    Thomas Höhler
    0

    When you are using the SQL CE, did you check the rights on the App_Data Folder? Just check if you can create a new node in the content area. If this fails with the same error this is likely a file-rights problem

    hth, Thomas

  • David Loosley 13 posts 33 karma points
    Mar 01, 2012 @ 18:37
    David Loosley
    0

    Thanks for your responses.

    Haven't got a scoobie why this happened.

    In the end I download a fresh copy of Umbraco 4.7 and loaded my packages again - works now.

    Regards

    David

Please Sign in or register to post replies

Write your reply to:

Draft