Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Samarth Pathak 6 posts 76 karma points
    Jun 20, 2017 @ 11:03
    Samarth Pathak
    0

    Umbraco Import Package Error?

    Hello,

    Greeting to all.

    I have created a theme in umbraco from which I have created a package and exported it. But when I am trying to import the package in newly installed umbraco it is giving following error while installation.

    Request error: The URL returned a 404 (not found): /umbraco/backoffice/UmbracoApi/PackageInstall/UploadLocalPackage

    Can anyone please help me out with this error and show me the way how to resolve it.

    Thanks.

  • Aluma 13 posts 106 karma points
    Jul 13, 2017 @ 17:20
    Aluma
    0

    This could be happening due to several reasons as follows:

    1) Ensure that you have appropriate permissions on your folders: https://our.umbraco.org/documentation/Getting-Started/Setup/Server-Setup/permissions

    Steps to alter permissions (Windows 7 or 8):

    a) right-click on the master web site folder of your Umbraco site; b) select 'properties'; c) select the 'Security' tab; d) select the profile you wish to edit permissions for under the 'Group or user names' section; e) click the 'Edit' button; f) enter your Windows login details if prompted; g) again, ensure you have the correct 'Group or user names' selected; h) select the check-box(es) for the appropriate permissions as suggested by Umbraco documentation.

    2) Ensure that your network/firewall rules are not restricting your Umbraco back-office from importing/installing packages. If you are on an enterprise/business network, there could likely be some network security rules that are preventing you from adding/removing packages. Talk to a team lead, and/or networking person.

    3) The file size of the package you're installing could be quite large. In theory, Umbraco should still install it, but I'm personally having this issue, and I have not yet found a solution aside from importing several smaller packages, or leaving out larger files/folders such as media.

    4) The Umbraco version of the package you're trying to install could be incompatible with the Umbraco installation where you are trying to import the package.

    5) The package you are trying to install could be corrupt, or encoded incorrectly. If you created the package then restart the package creation process, save the package, and try again.

    If/when you find a solution, please post it here. All the best.

  • Puck Holshuijsen 90 posts 352 karma points
    Aug 27, 2019 @ 08:25
    Puck Holshuijsen
    0

    I've had this same issue, and I found (at least for me) a solution.

    I left the normal projecturl to localhost:portnumber. After i changed it to an iis website url, the problem disappeared for me.

    I tried all of @Aluma's solutions, but none of them worked for me.

Please Sign in or register to post replies

Write your reply to:

Draft