Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • demo 12 posts 133 karma points
    Feb 27, 2018 @ 08:36
    demo
    0

    umbraco TypeError: Cannot read property 'dataY' of undefined. New 2018

    Hi every one. I have some error. Umbraco media picker doesn't display thumbnail images

    umbraco TypeError: Cannot read property 'dataY' of undefined.

    However, when I tested some solutions and examples, I found out why this problem is happening today ... The problem happens when I install the usky.slider package. Please help me figure out how to solve it. I do not want to remove the usky.slider package. I need this package

  • demo 12 posts 133 karma points
    Mar 05, 2018 @ 14:07
    demo
    101

    Try this solution and problem has been fixed... Now working good

    1) Src/lecoati.usky.ui/App_Plugins/Lecoati.uSky.Slider/lib/draggable.js

    angular.module("umbraco"). directive('uskyDraggable', function () { return { restrict: 'A', scope: {

    2) Src/lecoati.usky.ui/App_Plugins/Lecoati.uSky.Slider/uSky.Slider.html

             <div id="slideFluid" class="layer-show" ng-style="setSliderStyle()">
    
                 <div class="slider-revolution-layer"
                     usky-draggable
                      ng-class="{ selected: layer == $parent.currentLayer , hover: layer == $parent.overLayer }"
                      aspectratio="layer.type=='image'"
                      resize="layer.type=='image'"
    
  • Dave Shipston 17 posts 108 karma points
    Feb 24, 2020 @ 11:57
    Dave Shipston
    0

    Thanks for this, it also worked for me... well after I changed BOTH references in the .js file to "uskyDraggable" and then also referenced "uskyDraggable" in the html file.

    Once completed, I deleted all of the ClientDependency files in the App-Data section then reloaded the site and now it works!

    Thanks again for putting me on the right path

Please Sign in or register to post replies

Write your reply to:

Draft