Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at

  • Gayathri 55 posts 175 karma points
    Aug 16, 2018 @ 03:05

    Umbraco Embed URL not working throws an error ould not embed media - please ensure the URL is valid

    been trying to use the Umbraco Embed content type but the error says Could not embed media - please ensure the URL is valid.

    i have tried with , all these URL but none of them working any idea about this ?

    enter image description here

  • Dave Woestenborghs 3495 posts 12101 karma points MVP 7x admin c-trib
    Aug 16, 2018 @ 06:23
    Dave Woestenborghs

    Hi Gayathri,

    I have tried both URL's on a 7.11.1 install of Umbraco. Both work.

    One thing can be is that your website doesn't have access to the internet. The URL is retreived server side, so when the server doesn't have internet access.

    And just to be sure can you post the contents of your /Config/EmbeddedMedia.config file to be sure nothing is configured wrong in there


  • Gayathri 55 posts 175 karma points
    Aug 23, 2018 @ 05:14

    hi Dave,

    i can see the config in /config/embeddedmedia.config

      <provider name="Youtube" type="Umbraco.Web.Media.EmbedProviders.OEmbedVideo, umbraco">
            <requestParams type="Umbraco.Web.Media.EmbedProviders.Settings.Dictionary, umbraco">
              <param name="iframe">1</param>
              <param name="format">xml</param>
              <param name="scheme">https</param>
     <!-- Vimeo -->
      <provider name="Vimeo" type="Umbraco.Web.Media.EmbedProviders.OEmbedVideo, umbraco">
        <requestParams type="Umbraco.Web.Media.EmbedProviders.Settings.Dictionary, umbraco"></requestParams>

    not sure what am i missing

  • Leo Filippelli 4 posts 84 karma points
    Aug 28, 2019 @ 12:05
    Leo Filippelli

    It happens the same to me with Twitter, it has been working correctly for 1 year aprox and it suddently stopped working. Maybe it is related to the last Twitter upgrade?

    This is my config for Twitter:

    <provider name="Twitter" type="Umbraco.Web.Media.EmbedProviders.OEmbedJson, umbraco">
    <requestParams type="Umbraco.Web.Media.EmbedProviders.Settings.Dictionary, umbraco"></requestParams>

  • Dean Wiseman 26 posts 115 karma points
    Oct 03, 2019 @ 14:33
    Dean Wiseman

    I'm having the same issue, I'm not able to embed anything from any of the approved providers in the Rich Text Editor.

    Getting the same error:

    Could not embed media - please ensure the URL is valid.

    I've confirmed the server has access to the internet.

    I have tried numerous random youtube videos, Vimeo videos, etc. Nothing seems to work.

    Using Umbraco 8.1.4

  • carl 12 posts 81 karma points
    May 03, 2021 @ 19:10

    Has anyone been able to resolve this issue. I used to be able to embed Youtube videos and all of sudden it stop working. What's strange is it's working on my Dev and Test environment.

    Ps I'm using Umbraco 7.12.3

  • Dan 1279 posts 3890 karma points c-trib
    May 04, 2022 @ 07:47

    I have this issue on 7.12.3 too. Works locally but not on production. Anyone have any ideas (other than upgrading, which will be difficult to test if it doesn't happen locally)?

Please Sign in or register to post replies

Write your reply to: