Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Eli 15 posts 95 karma points
    Apr 16, 2019 @ 06:23
    Eli
    0

    Umbraco caching & uSync

    Hi,

    I am developing an Umbraco website. I have different environment (local, dev, staging, prod) and I am using uSync to sync the CMS content. This case always happens: after deploying the site to an environment, I can see that the usync folder is updated and has the most recent version I need. Until now, good. But when I browse the site I see some old content. I assume that uSync updated the DB, but Umbracos caches a lot of old files. I tried to delete App_Data/TEMP with no success. Tried to refresh the site by: http://

    How can I get the most up to date content?

    Cheers

  • Alex Skrypnyk 5272 posts 19275 karma points MVP 3x admin c-trib
    Apr 16, 2019 @ 13:34
    Alex Skrypnyk
    0

    Hi Eli

    uSync moves all changes, uSync doesn't remove content already created on the site.

    If you need to copy of the site from dev - you need to restore dev database on the live server.

    uSync - moves content and content types.

    Thanks

    Alex

  • Eli 15 posts 95 karma points
    Apr 16, 2019 @ 22:35
    Eli
    0

    Hi Alex, Thanks for the response.

    I don't understand - uSync actually tracked my changes. In the uSync folder I have the most updated version, which I need (for example, after unpublishing some content, uSync tracked it).

    But then when deploying the site and running the ApplicationPool the first time, uSync suppose to import all changes, doesn't it? so if something is marked as "published" in the DB but now uSync says it unpublished, it should change. This, sometimes, does not work for me, especially with unpublished content.

    Eli

Please Sign in or register to post replies

Write your reply to:

Draft