Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Gleb Kaplan 49 posts 125 karma points
    Apr 28, 2016 @ 12:25
    Gleb Kaplan
    1

    ModelBuilder - non-unique Document Type and Media Type aliases.

    Historically we have document type Folder. After upgrading to Umbraco 7.4, the Model Builder is not working, giving a message:

    Failed to build PureLive models. Alias "folder" is used by types Content:"Folder", Media:"Folder". Aliases have to be unique. One of the aliases must be modified in order to use the ModelsBuilder.

    We have thousands documents of this type. As there is no good way to rename the alias, is there any workaround?

  • Dennis Adolfi 1075 posts 6428 karma points MVP 3x c-trib
    Apr 28, 2016 @ 14:05
    Dennis Adolfi
    1

    Hi Gleb.

    This happend to me to in a solution. Fixed it by renaming the documenttype, but in your case i can see that this might not me a solution.

    Since you are upgrading, you might not use ModelBuilder? If you just want to remove the Error from your logfile you could disable ModelBuilder by adding this to your web.config:

    <add key="Umbraco.ModelsBuilder.Enable" value="false" />
    

    I know that it´s not a solution, but maybe it could help.

  • Dennis Adolfi 1075 posts 6428 karma points MVP 3x c-trib
    Apr 28, 2016 @ 14:27
    Dennis Adolfi
    0

    Apparently if you try to create a documenttype with the name Folder you are not allowed. See image: enter image description here

    But for you who upgraded i can see that it becomes a problem. Maybe there is a way to disable modelsbuilder for a specific doctype, and not the entire feature. That would be nice. Maybe someone knows?

  • Alan Mitchell 54 posts 270 karma points c-trib
    Oct 02, 2017 @ 14:51
    Alan Mitchell
    0

    Just came across this exact issue whilst upgrading an old website.

    For the benefit of future googlers - I fixed it by using Usync. By manually renaming the Alias of the media folder in the Usync definition file, it avoided the conflict.

Please Sign in or register to post replies

Write your reply to:

Draft