Copied to clipboard

Flag this post as spam?

This post will be reported to the moderators as potential spam to be looked at


  • Allan 37 posts 185 karma points
    Feb 23, 2017 @ 17:05
    Allan
    0

    Archetype - Upload field wont save PDF document

    Hi,

    Umbraco version 7.5.8 assembly: 1.0.6233.15010

    I have created a data type using Archetype.

    One of the fields within the Archetype data type is a standard upload field.

    The upload field accepts png's, jpg's, etc and works fine

    BUT

    it will not accept PDF's??? I am sure it used to allow PDF uploads...

    PDF uploads work on a standard upload field, but not in Archetype?

    Any advice/help on this problem?

    Many thanks in advance :-)

    Allan

  • Ravi Motha 278 posts 487 karma points MVP 3x c-trib
    Feb 23, 2017 @ 17:18
    Ravi Motha
    0

    have you checked the properties of the standard upload field, or other config option to prevent pdfs being uploaded??

  • Comment author was deleted

    Feb 23, 2017 @ 17:20

    I can't say I've heard of this before.

    Archetype simply wraps other property editors.

    The only thing I can think of is to make sure the upload editor has PDF enabled.

  • Allan 37 posts 185 karma points
    Feb 23, 2017 @ 17:24
    Allan
    0

    Agree that it is strange...

    I have not altered any configs on the upload data type so it is 'out of the box' so to speak...

    Have not altered any other configs either... added a few fields to 'image' media type but that really is it...

    Going to try a recycle of everything.

    * UPDATE *

    No luck on a complete recycle :-(

  • MatsStam 50 posts 195 karma points
    Feb 24, 2017 @ 08:30
    MatsStam
    0

    Seems weird that Archetype would cause this... I'd advice to check your logs :)

    And have you tried to create a field without archetype and does that upload a PDF?

  • Allan 37 posts 185 karma points
    Feb 24, 2017 @ 09:19
    Allan
    100

    Logs return nothing - only an indication that the node was saved and published successfully.

    I did create an upload field outside of archetype and pdf's upload without issue.

    Images upload to the Archetype field without issue

    Continuing to investigate...

    *UPDATE / WORKAROUND *

    OK - This is not a solution to the issue, but an effective workaround which may help anyone else experiencing this issue.

    If I change the field to a 'Media Picker' then (because the new umbraco easily allows it) I can choose to upload a new item (PDF, Image, etc) OR select an existing item from the library which actually enhances my Archetype data type!

    Apologies that my investigations go no further, but this is an effective workaround - Thank you for your help everyone!

    Allan

Please Sign in or register to post replies

Write your reply to:

Draft